Unable to load MeshFromPoints.rhp plug-in

I wanted to install the MeshFromPoints-Plugin, because Rhino has given me the link, when i wanted to do this Command. But if i want to install the plugin: "Unable to load MeshFromPoints.rhp plug-in: ID already in use"
What can i do to install the plugin? I don’t understand what the Problem is

Best regards

Close Rhino. Go to C:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins, find the MeshFromPoints.rhp file and delete it. Now put the downloaded one in its place. Right click on the downloaded file and choose “Properties”. If it has some message about it being blocked because it’s a potentially dangerous item downloaded from the internet, click on “Unblock” and OK.

Now start Rhino. You should be good to go. --Mitch


I am using Version 5 SR10 64-bit (5.10.41201.11145, 01/12/2014)

I cannot load MeshfromPoints… I followed your instructions and downloaded a new file, Window did block it, so I unblocked the file.

I still get "Unable to load … initialization failed>

Hope you can assist.



I still can’t load meshfrompoints. I’m using Windows 8.1 ( sadly) If I right click and unblock, & click apply, the file seems unblocked. Then when I go back and repeat it is blocked again.

I realize that this is not a Rhino problem, but I can’t load plugins.

Please can someone from McNeel assist

I see that here too.

Tip: When you download it, unblock it before you transfer it to your plug-ins folder. Then transfer it in. Works here. Your plug-ins folder is inside Program files and needs some special permissions it seems.


Thanks Mitch

I have moved past step 1 but …

I unblocked the file in the downloads folder, no problem & checked again to see that it was unblocked with another right click.

I copied the file into C:\Program Files\Rhinoceros 5.0 (64-bit)\Plug-ins

I ran Rhino and tried to run Meshfrompoints … initialization fail

So I closed Rhino and deleted the Meshfrompoints plugin in the above folder.

(A) Then restarted Rhino. now meshfrompoints no longer exists as a plugin.

I then copied the meshfrompoints plugin into the above folder and tried to install it as a new plugin. same error.

Then I deleted the plugin and rebooted and repeated steps (A) again — same problem.

What I did was this:

Run Rhino, call MeshFromPoints, followed the instructions to download.

Closed Rhino.

Right clicked on the .rhp > Properties and unblocked it, checked that I no longer saw the “Unblock” part.

In C:\Program Files\Rhinoceros 5 (64-bit)\Plug-ins, deleted the existing plug-in
(and answered yes to the prompt that I need admin privileges to do so)

Copied the downloaded/unblocked plug-in into the plug-ins folder
(and answered yes to the prompt that I need admin privileges to do so)

Started Rhino, called MeshFromPoints. The command asked me for points to input…

Windows 8.1, but I am running SR11RC and not SR10 - although I’m not sure there’s a difference there.


Hi All,
I’ve compiled my own rhp file using c# in Visual studio 2015, and I get the same error that Rhino can’t load the plugin. I’m running windows10, Rhino V5 64 bit. The plug-in is a simple wfp panel. I’m following the github example posted here: https://github.com/dalefugier/SampleCsWpfPanel

Any insight to what I’m missing would be greatly appreciated!


In regards to what you said to Mitch. If I right-click on my MeshFromPoints.rhp file there’s no option for “properties”.

Perhaps you are on a Mac? I doubt very much that the MeshFromPoints.rhp is compatible with the Rhino for Mac version.