Unable to give exact value in Model View component

I cannot get Model View’s knob double-clicking to work. Because of this, I cannot enter an exact value for any of the sliders, only sliding the value works.

I’m running version

Hi, that is strange. We have tried it on our end and it does not seem to be an issue. Does it also not work on the Beam or Shell View?

Yes, does not work on any of those components. I tried to reinstall Karamba from Package Manager, restart Rhino, install Karamba again, restart Rhino and try with a blank GH definition, but to no avail.

I’m running Rhino 7 SR20.

I’m wondering what to try next. For Rhino WIP, Karamba does not seem to be available on PackageManager so couldn’t test that either.

Hi, unfortunately this is an error we have never seen. Do you have issues with the mouse in Grasshopper? typing or clicking on other components? Are there error messages when you use Karamba3d?

Not any particular error messages that I wouldn’t understand. I also tested with just a new file so that it is not related to any specific GH file. When double-clicking, it opens up the GH component search menu “Enter a search keyword”. And I have tried rigorously to click everywhere around the slider knob, so it isn’t somehow offsetting some pixels or whatnot.

I also tried to disable some custom plugins on the Rhino PluginManager but it didn’t help.

I can double-click on other stuff in GH just fine (Boolean Toggle, Number Slider, Graph Mapper etc.) So double-clicking works just fine, but only Karamba’s sliders are problematic.

I understand that it’s a weird problem and hard to solve. I’ve used Karamba for years and this has never happened before. It might be time to reinstall the whole Rhino and see if it solves the problem.

BUT, as I was writing this and was wondering if there was a way to test Karamba on Rhino WIP, I opened it up and noticed that it was already installed (probably just the way PackageManager works). I tried the sliders there and they worked like a charm!

So to conclude, it seems to be a problem with my Rhino 7 installation OR the Service Release 20 (which I doubt).