Unable to edit subd plane using box edit in Rhino 8 after update

Hello guys,
I used to edit the dimensions of objects in Rhino by using the edit box to get the exact measurements. However, after the last update for Rhino 8, I encountered an issue where I couldn’t edit the dimensions of a subd plane. Every time I tried, I received an error message saying “Unable to transform the object”. This functionality used to work well for all objects, but now it’s only an issue with subd planes. Is there a solution to this problem?

Hi @yara.barakat2712 ,

I’m not seeing this issue using the same values you showed with a SubD plane.

Can you post your file please along with the text file saved from the SystemInfo command?

Hi @BrianJ and @yara.barakat2712
I’m seeing the exact same thing - see video.

-Jakob

System Info

Rhino 8 SR8 2024-5-17 (Rhino 8, 8.8.24138.16021, Git hash:master @ 70a9d2157099e610ee64adcb72458b4742ef050f)
License type: Commercial, build 2024-05-17
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 95GB)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro RTX 4000 (NVidia) Memory: 8GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-15-2024
Driver Version: 31.0.15.5161
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.8.24138.16021
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Users\jn\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

Thanks @Normand I got it now… it appears that the orientation is a factor.
https://mcneel.myjetbrains.com/youtrack/issue/RH-82084

1 Like

@yara.barakat2712 ,

Do you recall when this worked as expected? Was it in an earlier Rhino 8 service release or an even earlier version of Rhino like v7? We’re trying to narrow down where the change responsible occurred. Thanks.

@Jakob Normand, thank you, that’s exactly what happened to me.

This occurred shortly after the latest update of Rhino 8 . I am unsure of the exact date, but it was sometime between May 18-21, 2024.

1 Like