UI jumps in scale on Bootcamp



I recently rebooted my computer and installed bootcamp. Rhino now jumps in scale whenever I import a file. I have used Rhino on this computer previously on bootcamp with no problems. Help?


(Brian James) #2

I’m going to guess that you’re using Rhino 5 SR14… if so, please try these two commands. The first is TestToggleFileDialog, run that one first when you open Rhino. If it helps, you can add it to your start up commands in Options to be automatically run when Rhino starts. My hunch is that the scaling of the UI happened after a save. The second command which may help is the SetDpiAwareness command, click the one option in the command line to Disable high dpi scaling of Rhino. This was introduced in SR14 to fix issues for some users and if you disable it you should essentially be back to SR13 behavior. You can bring back the SR14 changes by running the command again if it had no effect and you are also running a high DPI monitor and are on Windows 10 1703.

Any luck?


Ah yes, TestToggleFileDialog worked. Thank you! The scale was now too big though, but to fix it I right-clicked on the Rhino-shortcut and under Compatibility checked the “Disable display scaling on high DPI settings”.