UCount value is not valid for this amount of points

Hi there,

I am attempting to create a contours from a mesh imported into grasshopper through a geotiff and have been following instructions in a guidebook. So far it is going well, but I cannot get past this error message when I try to connect my u count to surface from points, “The UCount value is not valid for this amount of points.” I can’t figure it out. I’ve uploaded the grasshopper file here with where I am at. Please let me know if you can help.

exercise 1 part 2.gh (14.2 KB)

This is a very common issue.

I have the expression for U as x+1.

I don’t have a plugin you are using so can’t test it but U Count for Surface From Points is typically one more than what was used on Divide Surface.

Here is a working example:

Thanks, I just took the output from my other slider, added one and popped it in and it worked! Thank you.

Piggy backing off of this thread - I had a surface I was manipulating after converting to a mesh, and I was trying to achieve the same result with a surface by dividing/recombining and despite having 51 branches of points from a divide U count of 50, having 50+1 in the surface from points is still giving the The UCount value is not valid error and not working.

Does anyone have any thoughts on what I am missing?
multiply by 0.gh (52.0 KB)

Flatten the SrfGrid ‘P’ input.

P.S. You might also want to flatten the Bounds ‘N’ input.

1 Like

Thank you!

That’s perfect.