Two tiny gripes

unhandled

#1

First one is related to panels :

I wish that the panel size would auto-adjust the first time a value is entered manually.

Second one is related to the wire display options :

This is too close to the “Disconnect” : it reminds me of a scene in Monsters vs aliens


(Tim Stark) #2

To the first one:
If you type in the search bar: “something, it will create a panel and adjusted the size.


#3

This also works with //


#4

Wow, thanks Tim.
Someone ought to write a “Grasshopper secret tips guide” some day


#5

Here’s more of those things:



#6

Fantastic !
But has proper documentation gone out of fashion ?
Is it just rummaging through forums now ?
Even the Grasshopper “Help” Toolbar points to the old Ning forum.

Excuse the tone, but I find it vexing to find out that stuff like that was out there, after so much time spent on Grasshopper.


(David Rutten) #7

It was never really in fashion for Grasshopper 1. Documentation has always sucked, mostly because the framework I wrote for it was cumbersome and inflexible, making it very difficult for someone other than the developer to provide docs.

I agree with you (as does basically everyone I know) that we need to do a lot better, and in fact the documentation system was the first thing we started writing on for GH2. It’s a bit back-burner now since there’s nothing to actually document as such yet, but I imagine as soon as some of the interface stuff becomes mature enough we’ll start again. We got trained linguists and everything on staff now to help out with this.

In the meantime GH1 will remain essentially one giant easter egg.

Yeah that’s clearly a bug, needs to be updated to link to discourse.


#8

:upside_down_face:

// Rolf


#9

Is this really a thing? I use the //Foo shorthand all the time and panels don’t seem to auto-adjust their size:

2018-05-16%2009_48_13-Grasshopper%20-%20unnamed

2018-05-16%2009_48_44-Grasshopper%20-%20unnamed

Maybe I’m misunderstanding :man_shrugging:


#10

That’s weird. I just tried it out here and it does work on my computer?
image


#11

Strange, I’m on:

image

image

Perhaps this is a later feature @DavidRutten?


(David Rutten) #12

Yeah I think it’s one of the many features added to GH1 for Rhino6.


(Tim Stark) #13

Yes sorry, in GH 1


#14

Many of the Easter Eggs (including the Shortcuts mentioned above) are together on a FAQ page: http://www.grasshopper3d.com/forum/categories/faq-frequent-questions/listForCategory

Perhaps there could be a more obvious link to this page, like under the “Learn” Dropdown?

I’ve been slowly collecting these Easter Eggs, but more often then not, I discover that @DavidRutten has already mentioned them in answering one question or another on the forum. The use of the “Time” component is pretty nifty.

My favorite (undocumented?) shortcut is in using context menus (RMB over canvas, group, or component) - for any menu selection with a unique first letter, typing that letter will select it. So then turning a wire to “Faint” is <RMB, W, F>. Maybe that solves your second gripe, @osuire?


#15

Hi Jokam,

<RMB, W, F> YES ! PERFECT !

Thank you so much !


(David Rutten) #16

That must be standard windows menu behaviour, I’m not doing anything special there.


#17

That’s how you recognize true genius…Even when doing nothing, your output is fantastic :slight_smile:


(qythium) #18

Metahopper’s Control Wire Display component is also really useful for quickly changing large numbers of wires all to faint mode:


#19

Yeah, I’m not a big fan of that one.
More often than not, I only need to change the wire display on some of the inputs, and I don’t like dragging this component around to keep it handy.

I organize my components with groups. Any wire going in or out of the group will be faint, and wires inside the group remain standard.
I also tend to separate chunks of definition with panels which I turn black and make into lines.
Between these chunks, I make the wires hidden.

If there was a way to automate this kind of layout, it would save me lots of time.


#20

Default Wire Display mode should be a system settings.

I’d prefer Faint as default.

// Rolf