Two finger zoom motion stop working

Yesterday between working sessions the zoom motion, using two fingers on the trackpad, stop working. I tried everything even complete software reinstallation.
Zoom works on every other app.

MacBook Pro
OSX Yosemite Ver. 10.10.3
2.7 GHz Intel Core i7
16 GB 1600 MHz DDR3
NVIDIA GeForce GT 650M 1024 MB

Thank you

Hi @Rhinomatic ,

In Rhinoceros - Preferences - Trackpad…

Do you have the “use two fingers…” box active?

Hi @Rodri,

No. And, it only have the option to “Use two fingers to pan and rotate views” which is a different motion.
It shouldn’t affect the zoom motion anyway. Which is opening in any direction the fingers on the trackpad. (correct me if I’m wrong)

There is no box for “use two fingers for zoom”

Also, if I activate the two fingers for pan and rotate, the message “Use option key with two fingers to zoom view” appears. I have to actually press “Click” on the trackpad with the fingers and move them pressing the pad and it will work.

Again the trackpad is 100% working in all other apps.

Thank you!

Pinch/spread zooming seems to be working here in my RC1 on 10.10.3 --Mitch

Here still not working. Reinstalled the software a couple times and nothing.

It seems to be working for me in RC1 (5A851).

Can you please post your entire system information (Rhinoceros > About Rhinoceros > More info… > Copy to clipboard) here?

Hi @dan,

Sure, Thank you!

Software information

Software versions
Rhinoceros version: 5.0 (5A851)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.3 (Build 14D136)


Third party kernel extensions
com.logmein.driver.LogMeInSoundDriver (4.1.48f99)

Hardware information

Computer hardware
Hardware model: MacBookPro10,1
Processor: Intel Core i7-3740QM CPU @ 2.70GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 650M 1024 MB
Memory: 1024 MB
Screen size: 1440 x 900
Displays: Color LCD (221dpi 2x)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple USB Ethernet Adapter
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: Apple Internal Keyboard / Trackpad

Bluetooth devices
Apple: Apple Wireless Mouse
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.2.7 310.41.25f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

Did you manage to fix it? I’m having the same problem right now. It was working perfectly a minute ago and it suddenly stopped. I did not change any settings.

Same for me, it seems that if I touch the Shift or Command button it stops working. When I close and reopen it, it works again until it repeats.

I still have the same issue on Rhino 8, I think this is a bug?
This happens whenever my Mac goes to sleep/close the screen. Need to quit and reopen to fix.

Same here, Rhino 8 for Mac, zoom / pinch / … stopped working. In all other apps it’s ok