Twitchy viewport navigation in R8

When I navigate around the viewport with rt-mouse button (rotate, +CTRL zoom, +SHIFT pan, all similar behavior) it twitches as I slow/stop dragging the mouse.

I’ve been posting in someone else’s thread about it, and while theirs was fixed I haven’t gotten a solution yet so I started my own thread.
https://discourse.mcneel.com/t/rhino-viewport-jittery-when-moving-camera/166725/33

I tried the Windows scaling that was discussed in the other thread, and it sometimes works for a few hours, but not always. Windows recommended scaling for this monitor is 150%. Yesterday afternoon and this morning the Rhino display was working properly in a maximized viewport at 100% but still twitchy in 4-view layout. After a computer restart the twitch exists regardless of viewport layout or scaling, 100/125/150%.

I’ve updated all drivers available from Dell, Intel, and NVIDIA with no change.
Checked NVIDIA settings as someone mentioned in the other thread, but no change.
Rhino Check For Updates says I have the latest service release of R8.

Gives me headaches after watching the geometry twitch for more than a few minutes, hopefully it can be resolved.

Rhino 8 SR6 2024-4-10 (Rhino 8, 8.6.24101.05001, Git hash:master @ 32c244aa711e0034e75bec2e87d093c764820b96)
License type: Commercial, build 2024-04-10
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.18

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 128MB, Driver date: 3-27-2024 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port 1
Primary OpenGL: NVIDIA GeForce RTX 4070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version: 31.0.15.5222
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8188 MB

Had the symptom show up in another way that I hadn’t noticed before–in the OffsetSrf command, if I’m moving the mouse slowly while clicking to change the direction of the offset, the arrows sometimes do a twitchy flip-flip-flip instead of single flip. The end result is correct but graphically twitchy.

I started to think maybe it’s the Bluetooth mouse, so I did a few things to troubleshoot and rule that out as a factor.
Turned mouse off/on.
Tried a different, wired USB mouse (with BT mouse turned off).
Tried each mouse individually on a different surface.
All no change.

Hi Joel - I am seeing this as well - thanks.
However, what I see is about the same in V7 - if you did, or do, use V7, is what you are reporting the same there?
RH-81625 Display Jittery orbit

-Pascal

I’ve seen it before, but I forget which version. From what I remember it was V6–it would have been 2017 - early 2018 so whatever version was current at that time. I also use Rhino at home and haven’t seen the problem there. A similarity that stands out to me is I was using a larger (>30" 4k) display when I had the problem before as well as now with my current work setup. At home I have a 27" display and haven’t seen any issues. Any chance Rhino doesn’t like the large displays?

Pascal I checked out your link and I think what you’re seeing is different than my issue. Mine doesn’t seem to be snapping to a grid, but suddenly backtracks and then flips back to where it should be. Like a couple of subsequent jarring jump-cuts in film editing. But the rest of the time it’s smooth tracking, not like a grid.

OK - yeah, I do not see that one happen here. I’ll add your clip. Thanks.

-Pascal

This morning maximized viewport is good at 100% scale.
It was twitchy at 125%, and now that it’s working well at 100 I’m not willing to try 150%.
Hoping for the best when I close this file and open a new one later today.

1 Like

Hello Pascal,

Jut bumping this item and adding context.

Having the same issues with “sticky” viewport navigation

  • Delays in modifiers CTRL shift and alt - sometimes they don’t catch when pressed or are delayed, and sometimes they stay active after release when going from pan to zoom for example. I have tested two different keyboards to rule out an input issue.

  • I also get viewport sticking or stuttering when navigating, HOWEVER it is most prominent when i am closer to the object…For instance looking a detail of a part where the rest of the part fills the field of view…it does not seem to happen if the whole object it zoomed out with a while margin around it in the viewport.

  • The modifier key sticky-ness and viewport stuttering seem very strongly correlated with my camera distance relative to the object.

  • Issues mostly go away in wireframe mode.

  • Seems less prevalent with smaller models/file sizes…although I have worked with much larger files and have not had this issue with the same models on version 7

Hope this helps

1 Like

@benjamin.moulton What’s your monitor setup? My display is perfectly smooth when working at home on a 27" monitor, but twitchy at work on a 34". This is the main difference that I can think of, and I had the same problem with a previous Rhino release (R6 maybe?) at a previous job with 34" monitor as well.

Sometimes when I change my Windows display scaling to 100% (down from the recommended 150% or my preferred 125%), the problem goes away in a maximized viewport, but still happens in standard 4 view layout. And sometimes it’s still present at 100% scale.

Regarding your feedback:

  • I haven’t had the modifier issue.
  • It is more exaggerated when zoomed in since a ~2° rotation (for example) results in a larger perceivable translation when a part is right by your eye compared to sitting at a distance. All the parts I work with are fairly small and of a similar size (eyewear) so I haven’t had experience with small vs large parts.
  • For me there has been no difference between wireframe/shaded/rendered modes.

Feedback is appreciated. Hopefully this can elevated to the point that it can be resolved. Working between multiple software packages, Rhino has always been my “aahhhhh, welcome home” package of choice, but now on my work computer the stuttering/twitching gives me a headache so I’m doing my best to learn SolidWorks.

Had one more layer of the onion unfold today–

Opened files while scaled at 125%: twitchy.
Changed to 100% while files were open: all files smooth in maximized viewport.
Opened another file while scaled at 100%: this single file was twitchy, others were still smooth.
Scaled to 125% with all files open: all files twitchy.
Scaled back to 100% with all files open: the single file went back to twitchy, others were still smooth.
Closed twitchy file, scaled back to 125%, opened the file again: all files twitchy.
Scaled back to 100%: all files smooth.

:melting_face: :exploding_head:

So I have to change the scaling to 125% before opening any file, then scale to 100% to work.

Just for fun I tried a 3 Viewport layout (which I’ve never used before) and the half-screen viewport is smooth while the quarter-screen viewports are twitchy, regardless of what the actual view is (Top, Front, Perspective, etc.) or display mode.

Installed SR7, no change.
Installed SR8, no change.
Tried changing my laptop and secondary displays to the same scale to rule that difference out as a possible point of weakness, no change.

Is this being addressed?
It’s severely limiting in my work. And sanity.

Installed SR9, no change.

I will try installing the SR9 patch as well. The problem comes and goes. I have now been able to track down a specific cause. Generally, the closer my viewport camera gets to an object in the viewport the more often it happens. I’m pretty sure I’ve ruled out my mouse and keyboard because it does not happen in other programs.

It might be related to the viewport visualization style.

I suspect it may have something to do with my graphics card driver or settings interacting with Rhino in some way.

Tried using my work computer at home–different keyboard, mouse, smaller monitor. I still have to open files at 125% scale and then switch to 100%, and then only work in a maximized viewport. Otherwise glitchy just like my setup at work.

Is anyone else running an RTX 4070 laptop GPU?