Twinmotion bug?

This one pops up every time I open the WIP.

The Twinmotion direct link is for both V6 and V7. I have already downloaded the newest one. In V6 it works as it should (no warning message - and the added Twinmotion drop down in Rhino). Twinmotion is loaded and enabled in V7 also.

Philip

I think you have to download the newest version from their site:

Hope this helps

Yes, that’s what I have done (that dialog is lying) - I have the newest version. It works with V6, but not with V7. That’s why I thought it would be a Rhino V7-problem.

Philip

Any idea @dan, @pascal ?

Philip

I do not have any idea, no. In general v6 plug-ins work in V7 but I don’t know if that is ‘guaranteed’.

-Pascal

Ok, thanks! I’ll ask the Twinmotion team.

Philip

Has anyone found the solution to this problem, since I switched to Rhino v7 I have this issue.
Now I can’t use Twinmotion direct link. It’s so frustrating…

I made a comment on the Twinmotion forum, but didn’t get any clear answer - and no answer at all from the developers. Then I tried to make an official bug report directly to the developers, but their bug report software (?) crashed… Haven’t tried again after that (haven’t needed Twinmotion for a while). Still have the same problem though, so I’ll try again, when I have more time.

Perhaps you also could file a bug report to the Twinmotion developers?

Philip

Hi guys -
I’m having problems understanding what the issue here actually is.
Does TwinMotion run at all in Rhino 7? Or is the issue only that you are asked to download the latest version? Details, please.
-wim

Philip

What happens when you click “No”? What happens when you click “Yes”?

This mirrors my experience with Twinmotion support. The forums are difficult to use to the point of uselessness and answers are rare and rarely helpful. TM feels like software with amazing potential, but it’s definitely got bugs and doesn’t have good support.
It’s weird, because most Unreal Engine software has good support and active user forums.
I’ve been leaning on Enscape, simply because it works reliably… but I want all the hot features of TM… but it crashes almost every time I use it. I’m keeping an eye on TM but not gonna waste any more time until they get their sh*t together support-wise.

Yes, it’s a bit sad…

Philip

First a clarification… The dialog pops up when I open a file from the Rhino splash screen (any file - even “new”) - not when I start Rhino.

When I press “No” the dialog goes away and the file opens. If I click “Yes” the file opens and Safari opens this site.

Philip

OK, getting really specific with words then:

It sounds like the TwinMotion plug-in works in both Rhino 6 and Rhino 7, but in Rhino 7 it pops up an update warning. If you click No, everything works as expected. If you click Yes, then you are taken to the update page, where no update is availble.

So the bug is that the Twinmotion plug-in says there’s an update available when there isn’t.

Otherwise, everything works as expected. Is that corect?

Sorry, but no (see below).

That’s one of the bugs, yes.

Unfortunately not… In V6 I have the dropdown menu:

In V7 I don’t:

… and still Twinmotion seems to be loaded and enabled in V7:

I don’t understand…

Philip

Now I noticed that the pop-up warning is perhaps not actually lying - sort of… The V6 version of the plug-in is somehow newer than the one in V7 (2020.2 versus 2020.1). That is really strange, because it’s the same downloaded file…

Philip

Thanks for all the details. I’ve pointed some of our internal contacts at Unreal toward this thread.

Thanks Brian!

Philip

From Twinmotion:

Our QA has tested this on Mac, and says that a workaround is to reinstall the plugin. Apparently the plugin was automatically installed when he installed Rhino 7?

Rhino did auto-load the Twinmotion plug-in from V6.