Tween through surface not following the massing

Divide surface rev2.gh (17.6 KB)
twist.gh (13.5 KB)
twist.3dm (14.8 MB)


I was trying to equally divide the surface of the twisted massing by using Tween Through Surfaces (to get the result like the image), but the the resulted tween lines aren’t following the intended massing; even if I changed the selected list item of the surfaces to make them match the massing, the tween line direction isn’t the one I wanted ( not sure if I am making sense here). Does anyone know why this is it? Is it because I twisted the surfaces too much?

I’d also tried Iso Curve the Brep surfaces ( I broke down the polysurfaces to individual surfaces first), but even if I set the UV number the same, the division points are matching along the joint edge.

this might work, it divides the 4 non-planar Brep edges and creates 4 points surfaces between them


twist_Re.gh (27.8 KB)

you can also get similar results using Putterfish tween surfaces along curve, using one or two curves as guides (not 4)

1 Like

@inno Thank you again for helping me out again.
I tried to set another surface for it, but the same problem occurred, could you help me look at it again? Also, may I ask what role FLIP plays here?

I also tried Tween through Curves, but would like to know how to flip the direction of those tween lines.
twist_test.gh (20.7 KB)
fork_test.3dm (244.7 KB)

first step of the definition is to isolate the edge curves, and it does so by selecting the non-planar curves of the Brep (this might be a limitation)

the flipping was there to unify the direction of all the curves, otherwise you would get points in the opposite order (see the 4 vectors, 2 of them are traveling in opposite direction)

this allows you to manually flip the curves if needed, for instance here curves 0,1 or 2,3 need to be flipped

when all the curves are pointing in the same direction the 4pt surface will produce the correct result:


twist_test_Re.gh (44.0 KB)

Last but not least :slight_smile: if you right click on the Brep Parameter in choose “Internalize data”, it will store the Geometry of your Brep inside the GH file, so there’s no need anymore to also attach the Rhino file :+1: will save you some time

1 Like

Thank you very much for your detailed explanation!