Many commands should be merged. For example…
Rhino 6 introduced Parabola3Pt command. This is a misnomer because the older Parabola command also uses 3 points. In my opinion, the Parabola3Pt command should be merged with the older Parabola command.
DevLoft should be an option of EdgeSrf.
OffsetMultiple should be an option of Offset.
ShowDir should be merged with Dir.
SetMaximizedViewport should be merged with MaxViewport and renamed MaximizeViewport.
Nobody needs Unisolate command because Show command does almost the same thing.
Nobody needs PlaceHole command because MakeHole command does the same thing and it has more options.
Nobody needs Splop command because OrientOnSrf command does the same thing and it has more options.
Nobody needs Helix command. The Helix command is superfluous because Spiral command does everything (and more) than the Helix command.
Rebuild and RebuildUV should be merged into single command.
FitCrv and Fair should be merged with Smooth.
RotateCamera should be merged with TiltView.
Few people can memorize differences between FlattenSrf, Smash, Squish, SquishBack, SquishInfo, UnrollSrf, UnrollSrfUV, ApplyCrv, CreateUVCrv, FlowAlongSrf, Splop, OrientOnSrf, ProjectToCPlane, and Project. These commands should be merged into just two commands: one command projects objects on the construction plane, while the other command projects objects on a 3D surface.