Turn off Persistent History?

I seem to recall checking this or selecting it somewhere to see how it worked on a project recently. Turns out History is now persistent til the end of time on all work sessions. I can deselect it on the status bar at the bottom of the interface but it selects itself for the next command. This is slowing Rhino. I cannot find where to turn this preference off. Perhaps someone can remind me.

RMB History on Status Bar > Always Record History.

No. That doesn’t work. It turns on again with every new command. NOt only does Record HIstory become activated, but Always REcord History becomes activated as well. This is a problem.

Hi - when you deselect Always Record History on the status bar, history doesn’t get turned on by itself again. If it does, it means that something on your system is overriding default behavior.
Note that dimensions have their own history setting that can be changed by running the History command and setting RecordAnnotationHistory=No.
-wim

It did for several minutes in my case, for every command. I triple checked. Then it stopped somehow.

Can I ask how this affects dimension associativity?

It will make it so that new dimensions no longer are associative.
-wim

Does this associativity (when it is active and working properly) act between layout and model space?

Yes, it does.
-wim

Great. Now that’s a handy thing to know. If it’s documented I must have missed it. I’ve had it off for a great many projects for some reason.