Tubing error closed lines/open lines


I recently started to use Rhino 5 on Win 10.
I have the problem that I’m not able to built a closed tube out of a closed line (multiple straight lines).
The problem only occurs with closed lines ,as soon as I take out one part, having an open line consisting of multiple straight lines, the outcome is correct.

Hope the pictures help.
Thanks in advance,

Hi Moritz- it is interesting that the open version works OK - I think I’d expect that to miss some miters as well, perhaps not closing allows the segments to be ‘off’ the true answer enough to join. In general non-planar polylines will not make the joints reliably - I’d never noticed the open/closed difference though. I’ll experiment…


Hi Pascal,
thanks for your efforts. I never experienced something like this in Rhino 4, as long as the line is closed properly.
That the miters doesn’t look like made of two tubes crossing each other, supports your suggestion that this is not a reliable result at all. Maybe a close up of the joints may help you identify the problem. Could somebody post a screenshot of proper miters built by Rhino 5? .


Hi Moritz - actually, in testing this, it looks like the result on the open polyline, when closed with a pipe on the missing segment, works out well - the intersections are correct and the whole thing can be closed with clean miters. Which suggests that the closed case should in fact work…


Hey Pascal,
I tried to set everything back to standard but with the same result. Somehow it works as long as the single segments are planar. As soon as I lift one point, all miters are off… Could it have something to do with tolerances?

I use this tool quite often. Otherwise I wouldn’t care so much.

Yeah- this is the way it is I’m afraid - mitering out of plane curves is not ‘part of the deal’ in Pipe - it might happen sometimes, but it is not expected, is what I understand; so for now, that is a given, I believe. But the closed/open thing is interesting and my tests suggest that it might be reasonable to make that work better.


Hm, like I said. No problems with this in Rhino 4.
Is there a way to modify the tolerances? I don’t do rocket science, so a working miter would be better even if it is not that precise anymore.

Edit: Ok, I changed the absolute tolerances from 0.001 to 0.1. Seems to work now :slight_smile:


now it’s gettin strange. I first tried it with a simple 4 segment polyline and it seems to work.
With the initial polyline I get this result:

The diameter of each segment is effected by the angle/direction it joints the connecting the next. Depending on where I start I get different results. None is of use for me…

Any ideas left?

Well, not quite none, just different. If you need the closed loop, I’d say the simplest way is to make the partial one at the tolerance you like, then add and trim in the missing link. Ugly, I know…


Not quite what I expected… I may underestimate it, but this does not seem to be a very difficult task for the program.
Why does it work so different to Rhino 4? What changes have been made to this specific tool? I matched all my parameters with my old ones. Doesn’t work either.

With the different diameters it doesn’t work at all. With the missing link I need to do a lot more steps than I’m used to.
And this is annoying me already while I write about it. I do really a lot of these closed tubes in my concept phase. I would rather try to get back a Rhino 4 license from somewhere than doing it like you suggested.

No other idea out there?