"True colors" in Shapediver viewer

Hello SD Team,

I have a question regarding colors. How can we display in the viewer the same color that the user choose in the interface? I am not looking for realistic textures so I would like the black to appear black. Even when all the lights are disabled, the default environment modifies the color of the object in the scene (I tried all the presets and none seems to work well).
However, colors are ok in the export file.

Example in this screenshot :

SD : ShapeDiver

Do you have any advice to be closer to the “true colors” in the viewer?
Thank you,

Hello @Leeora

A bit of background, as we are working here in a 3D environment with actual lighting, the displaying of true colors gets a bit tricky, because it depends on the lighting and the environment map.

In your case, you can adjust the “Advanced Rendering” Settings in the “Scene Settings” tab. If you change the Output Encoding and Texture Encoding to “Linear” and disable the “Physically Correct Lights” your results should be much closer to a truer black.

Additionally, try the environment map “None (LDR)”, in this case you will need the intensity of the lights again.

Hope this helps!
Cheers, Michael

Hello Michael, great advice, it works much better now. Thank you!