Trouble with turntable : it spins out!


I have this problem on several computers, so I don’t think its a bad settings… When I use the ‘turntable’ command, the action is more like a spiral. Its spins, but it get further and further out of whack until it eventually leaves my field of view. When I stop the dialog, the geometry “jumps back” to where is started.

The old version used to spin my geometry nicely in place.

I thought it might be my Space Navigator, so I unplugged it just in case. No change.


Have you checked to see if your computer is out of balance?


Is it possible that your Space Navigator driver is at fault? Just unplugging it might not solve the issue. I don’t have a Space Navigator and my turntable command works just fine.



Yeah, no problems here (I don’t have a Space Navigator either). By the way, my previous comment was just a joke, of course. :wink:

(John Brock) #5

Turntable spins around the viewport target. The only thing I can think of is if something is causing your viewport target to move.
Try this:
Open the Properties Panel and leave it docked to the side of the screen. When nothing is selected, it will display viewport information including Camera and Target location. Run Turntable and watch the target coordinates. They should not change,


Two of you guys really helped! I watched the camera target and it was definitely drifting something fierce.Good test! I then checked out my navigator one more time … and found the culprit. It was a very-well hidden new setting that came in a recent driver Space Navigator update.

These settings are not seen anywhere in the standard control panel; they are only available & visible when you set one of the buttons to trigger a ‘pop-up menu’ (set via from the control panel) and then press that button. You get a small pop-up menu with several options : you want to go the ‘rotation center’ and turn everything OFF and then click on ‘hide’ so you don’t see the small blue cube every time you use the navigator. (It’s supposed to help you know where the center is.)

Yes, someone thought a tiny blue cube in the middle of your screen would somehow help. All of these new rotation features are both well-hidden and bug-like. Thanks, 3D Connexion / Logitech.


you can also access these options by typing Spacemouse and choosing PopupMenu on the command line…


Hey, great tip! Thanks for that info … and that’s why this forum rocks!