Trouble with holes when subd because of not merged edges

Hello,

I’ve been trying to do like a 3D Moebius Strip with holes in Grasshopper. For that I used “twist” and “flow” nodes from grasshopper. The idea was to start from an extruded polygon and twisting it around Z axis and after that making it adapt to a circle, so it would form the 3D moebius strip I’m talking about.

The problem is that in the intersection of the bended geometry it seems to be not merging the edges from the 3D model, so when you try to apply a SubD to the geometry appears a giant hole where it shouldn’t have to.

Would be great if someone can tell me what to do, I tried deconstructing the mesh and merging it again but it seems to do nothing.

Thanks! :smiley:

Mobius Strip 3D - Voronoi V04 - FINAL.gh (17.7 KB) Imagen 312

Welding your mesh vertices within a given tolerance would help you to solve the problem.
You’ll need meshedit plugin.


Mobius Strip 3D - Voronoi V04 - FINAL_re.gh (20.8 KB)

1 Like

I didn’t know about this plugin. I tried what you say and it works! Thanks!!