Trouble outputting layout with raytrace viewport

I’ve created a layout with a perspective viewport, set display mode to raytraced, and waited for raytracing to complete. I want to end up with a jpeg of the completely raytraced image. Whether I use the print command or viewcapturetofile, the output does not look like the raytraced image in the Rhino viewport – it looks more like the viewport at the moment raytracing starts. no shadows, etc. Is there a way around this?

If I print or viewcapturetofile from the perspective model viewport, I get the result I expect – a jpeg of the completely raytraced image, with finished shadows, etc. As a workaround I can save named views in the perspective model viewport, but I’d much prefer to be able to print from views in new layouts, where I can toggle between them quickly, turn layers on/off, etc.

Did you try to press the print button and then paste it into photoshop or gimp?

The print screen button may be labeled as “PrtScn,” “PrntScrn,” “Print Scr,” or something similar.
Then in Photoshop make a new canvas and press Ctrl + V to paste the screenshot.

Alan,

I’m familiar with using the print-screen function to create a screenshot. I’d prefer to select ‘print’ from the ‘file’ drop-down menu in Rhino, or type “print” into the Rhino command line, to have access to the controls there (set resolution, etc.). I’ve attached screenshots to illustrate the problem. If I print the layout to a jpeg from the print setup window, the jpeg output looks just like the print setup window (i.e. not showing the shadows like the raytraced image in the layout view).

Thanks,
Matt

For the record, the problem was that my computer has both an NVIDIA GPU and a less powerful graphics card, and Rhino was using the wrong one. The solution was changing the NVIDIA GPU’s settings. I didn’t come up with this on my own, it was suggested by Holo in response to a separate thread about a separate problem.

@mbabcock Can you link to the other post with relevant nvidia settings?
In layout workspace my Raytraced window (detail) displays as raytraced only when it is the active window (detail). Otherwise (and while printing) it shows up as rendered only.

Hi Mikolaj - that would be this one:


-wim

1 Like

Thanks Wim, but these are my current setting (using RTX 2070) and still I’m getting this behavior (in case my description was not clear):
https://www.screencast.com/t/H4DwMaPQ

Hi Mikolaj - in that video you keep interrupting the raytracer, making it start over again.
When I test this here, deactivating the detail will keep the raytracer in the detail update the image until the goal is reached. When I print that to PDF, the raytraced image is printed.
-wim

Yep, as soon as I deactivate detail it starts over. Even if I keep it active until it is completed - printing shows the detail again as rendered only. I’ve tested it on 3 different machines with nvidia cards. Could there be any other setting relevant (apart from nvidia settings)?

Yes, it starts over. Then let it complete. Then print. Doesn’t that work on your end?
-wim

Wim, it doesn’t work. Just tested on 4th machine with GTX card only. Please see images attached
layout-raytraced test2 001.pdf (1.5 MB) .

That’s not at all what I’m seeing here, too.

I’m on SR 6.18

Here is the file I used if you want to test against your build @wim:
rtToPdfTest.3dm (850.5 KB)

Thanks guys - I see this now.
My custom Raytraced mode has edges showing while my Rendered mode does not. In the detail, the edges were showing and so I assumed that the Raytraced mode was successful. Testing with reflective materials shows otherwise.

At any rate - apparently, this was on the list already - RH-48629.
-wim

Hi guys,
it seems not only with double graphic cards the issue appears. I have radeon RX 580 on my second machine and this problem is also visible: no raytrace layout is printing.