Trouble Joining Hub to Wings

To construct this, it’s from a wing that’s mirrored & the hub revolved as surfaces.

The wings go into the hub with a trim section you can see, it trimmed.

No matter what I try to join them from this point I can’t join the hub with the wings, it’ll stay separate as surface or solid & the wings will join…

The error for merge is “too far apart” and they were trimmed … set tolerance to 1mm, failed; fails intersect & anything else as a srf or solid …

Looking for what I must be doing wrong thanks for thoughts.

.

I think it’s hollow, I offset to the inside in solid tools of a rotated curve surface, saved it as STL & it shows the hub isn’t a solid.

No clue on converting, tried the obvious, a novice, thx.

Without having the file, it’s difficult to tell exactly what’s happening, but from your wording I can suggest a couple of things:

Assuming the wing parts are surfaces and not meshes, in order to “join” them with the hub, either a Boolean operation will be necessary, or some combination of splitting/trimming and joining (a “manual” Boolean). I suggest you read the faq on both Boolean operations as well as “solids”, those will give you a better understanding of how things work and a handle on diagnosing and fixing the problem.

http://wiki.mcneel.com/rhino/booleanfaq
http://wiki.mcneel.com/rhino/faqclosedsolids

Feel free to post the Rhino file here as well, someone will have a look.

HTH, --Mitch

Thanks for the ref’s, it looks like the hub was definitely the problem not the wings & it seems from constructing it.

In analysis, environment render it showed layers, exploded & rebuilt & it got rid of that but seemed to have duplicates of the construction of it from a curve.

Deleted those down to a single surface now, trimmed it again & in the process of trying to turn that into a solid w/o messing with the wings.

It needs end caps, was trying to add those to create a solid, this is after the trim.

So I hid the wings and the hub has holes in it on both sides like this is why.

Do I need to intersect before trimming or some sequence ?

Tried patching them some luck but it didn’t completely fill, wouldn’t select some of the edges, I like to

find out why it did this.

Solved, and the wings were the problem … where the patches are the wing part didn’t make full intersection from defects, it was really closely parallel so never saw it wasn’t fully in contact.

thx for responses, reviewing it all helped.

I had to rebuild from surfaces so paying attention this time every step and hit the same failure to merge surfaces.

[The wings need an NDA or I’d attach the file]

This is the hub join of the wings to the barrel, it’s been trimmed.

From here what’s the next step, tried merge, it fails & reports the edges are too far apart ? … and so on, nothing seems to work.

Also tried to just offset to solid figuring a union would join them later as solids, that failed so I’m stumped.

The barrel shows it’s not a solid after capping ends so I’m missing some step & not finding it on how to create a solid from a barrel surface with circles for ends?

Appreciate a look, thx tom

The wings have been trimmed, yes. But the cylinder has not. Is that the part that is not working (i.e. trimming)? You cannot start joining these before the cylinder has been split.

It was the rotate after getting the first wing correct, it had defects that showed up when I saved it as stl, went back to a surface single, redid the rotate & it was ok this time just finished a rebuild without fillets and got a union !!!

Stoked, seems I was doing it ok … no clue on why, I had done the routine at least twice before w/o the defects.

Just found this reply, I have gotten through this step and able to union wings & hub as a solid. The last tweak got a union to work.

The hub is separate here, joining them was a further step so why would it need split is my question, trying to get how it’s used?

I’m on the last step of the propeller now, trying to trim out an extruded spline surface, also split, extruded as a solid after trying surface & nothing is working to just remove the core.

Real happy with the shapes I’m getting …novice for sure, I could be hitting enter instead of clicking it, trim does that.

Finally got it, made the internal a solid as a separate file, inserted that & moved it into place.

Then tried Boolean diff on it and seemed to fail but no msg, flipped it over and it hadn’t pierced the top …

Very happy camper, I did this from scratch pretty fast, clues from reading similar woes on the forum so thks.