TriRemesh Issue

Can anyone explain this?

Using the component to remesh my Mesh is okay, while it returns a null by using code.

Many thanks… (9.7 KB)

I found it when I restart Rhino. It works again.
Since the import ghc Is not stable… The same thing happens before for using this library to compute Convex hull.

Any suggestion for using ghpythonlib ?

Hi @asdbeen53

I can’t reproduce the issue - your code works when I run it.
Which Rhino version are you on?

Hi Daniel, thanks for your reply.

Version 7 SR26
(7.26.23009.7001, 2023-01-09)

Yes when I restart my rhino it works again.
This does bother me sometimes. I have tried an iteration algorithm with triremesh before. Sometimes it will suddenly return a NULL result.

After that I will fail to run this triremesh syntax (even just for one time remesh). It will keep return Null until I restart my Rhino, then it works again.

Wonder if anyone faces the same thing before…

I suspect it is because my import of ghpythonlib (Node in Code) is not stable?

Is there a DLL. file I can call this method like your plankon dll?

Sorry I’m not sure what’s going on there with NodeInCode.

As for a dll to call the remesher directly without going via NodeInCode - not yet, but it is planned.

1 Like

Thanks for your work!

1 Like