Trimming a lot from file yet speed still slow


#1

Hi,
V4
I have given my file a good trim, remove unwanted items, deleted dimensions, etc. Still it is as slow as before.
Does it remember what used to be there ?

How do I cleanse or purge memory of this file ?

I have a lot to add yet with it this slow already I fear for the future.

Would exporting it out to a new file solve things ?

Are there ways of speeding things up.

TurboCad chap said dont draw many rivet holes, draw one as a block then create block instances. Standard practice in CAD he said else the program sees every hole as a separate item.

Thats a new one on me, is this applicable to Rhino ?

I did find when adding rivet holes things slowed down.

I create one solid cylinder then copy it to the rest of the locations I need to ‘drill’ out holes in my solid, then do a boolean and create the holes.

He showed me a block instance (if that was what it was called) of a circle in 2D view, does this apply though to 3d view ?

How would I use this method to create my cylinders and position them before punching holes with them into my solids ?

I have a large jpg plan in the scene, I often have a few more. Black/white and smallest file size I can manage.

Its turned off.

Does Rhino run things speed wise as if all layers are turned on ?

Steve


File size/speed/efficiency etc
(Steve Baer) #2

If objects are not visible because they are hidden or their layers are off, then Rhino will not attempt to draw them. In other words, the display should improve as more objects are hidden.

We did do quite a bit of work in V5 in attempts to speed up display, you may want to try the evaluation version to see if that makes a difference.