Triming Crvs with sphere _Error

Hey guys,

I’m trying to trim crvs with joined spheres object. It doesn’t work. When I was trying to do the same with boxes or revolution Srf it worked. Does anybody know why?

Many thanks in advance :tulip:

191022_Trimint crv with sphere_Error_forum.gh (19.6 KB)

WARNING!! This file is extremely slow to open… In fact, it fails to open due to memory error:

memory

Also, it depends on R6 Relay components so without a screen shot of the code, can’t be used properly in R5.

missing

It looks like you used Join instead of SUnion to join the two spheres? Wait, nine spheres! Most of which (all but one) are “Invalid Surface”.

1 Like

Thank you for prompt replay Joseph_Oster!
I’ve tried with SUnion, still no succes.
Yes,there are 9 spheres in the moment. I would like to get kind of metabal effect after the union.
Here the screan shot:

Do you have hidden wires connecting the relays to the Box? What a pain… :frowning:

Much later… My old laptop running R5 was struggling to view the model and edit GH, plus the “Invalid Surface” errors were suspicious, so I added a yellow group to average the points, get a vector back to the origin (0,0,0) and move the points and box reference plane. Way better!

It fixed most of the “Invalid Surface” errors, though one remains:

Finally, the ‘B’ inputs to all three Trim with Brep components needed to be grafted:


Trimint crv with sphere_Error_2019Oct22a.gh (18.9 KB)

P.S. On a hunch, I rounded the point coordinates which left no “Invalid Surface” errors, so all three Trim components were happy. Skipped SUnion as unneeded.


Trimint crv with sphere_Error_2019Oct22b.gh (36.6 KB)

1 Like

Hi, its Tokyo time here, I’ve just woke up.
Thank you so much! Wouldn’t ever guess that rounding of points and the position can be a problem

Have a great day :slight_smile: