Trim Crash

I’ve had something weird suddenly happen to a file. In this sample file if I try to trim off the bottom of the red extrusion using the plane, the whole exstrusion disappears and Rhino crashes with a memory allocation error?? Split works.

trim error.3dm (144.4 KB)

Same behavior here.

If I ConvertExtrusion the red object the same behavior.

However if I Explode the red object then it trims properly.

Explode the red object and then Join the three parts the same behavior.

So it appears the joining is causing the problem.

Rhino 7 SR8 2021-6-9 (Rhino 7, 7.8.21160.05001, Git hash:master @ 9070c33ca93e552d4fa2ae1038d65e6ff1ded0e8)
License type: Commercial, build 2021-06-09
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 5-6-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 462.59
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-6-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Orca3D V2\Orca3D.rhp “Orca3D”
C:\Users\dcock\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.2\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows”
C:\Users\dcock\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows”

Rhino plugins that ship with Rhino
D:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.8.21160.5001
D:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
D:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
D:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.8.21160.5001
D:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
D:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.8.21160.5001
D:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
D:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
D:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.8.21160.5001
D:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.8.21160.5001
D:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
D:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\dcock\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”
C:\Users\dcock\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.21.831\SectionTools.rhp “SectionTools”

Hi all -
This is a know issue in the service release candidate. It has been fixed and the next release candidate should be fine.
For now, revert to Service Release 7.

1 Like

I thought instead of trying to roll back I’d just use the WIP…it worked for a while, then DID appear there?? What the–?

Still seeing this in SR8.

As Wim said, we’re aware of it and I think it was fixed for V7 SR8 SRC2, what what supposed to be released this week.

The best option for now is to uninstall V7, reinstall V7 SR7.

That said, we very much appreciate the users that use the Service Release Candidates. This is how these problems are caught so they can be fixed before the actual Service Release is available.

V7 Service Release 8 Candidate 2 was released several hours ago.

The trim bug appears to be fixed based on some quick testing.

Exactly which version of SR 8 are you using?
Rhino 7 SR8 Release Candidate 2 for Windows and Mac (7.8.21168) which was released today
Rhino 7 SR8 Release Candidate 1 for Windows and Mac (7.8.21160) which was released last week ago and has the bug

I confirm that Today’s service release candidate (Rhino 7, 7.8.21168.01001) candidate solved the issue.
Thank you everyone