Trackpad Navigation Changes Overnight

This happens to me every morning… I have no idea how to force it to happen in order to reproduce nor do i know the specific timeframe when the switch happens…

reporting anyway :wink:

I’m using Rhino on/off throughout the day (typically)… (sometimes all day but the same thing happens overnight)…
navigation works fine (two finger orbiting with trackpad)

when i open the computer the next morning, assuming i didn’t quit Rhino the night before, the trackpad no longer works right… i can still two-finger pinch for zooming but orbiting with two-finger drags no longer works… instead, i have to two-finger-click-hold-drag for orbiting (which is no good for me)…

to fix it, i relaunch Rhino and it’s back to normal.

basically, i have to quit rhino every day and start it fresh… (ie- not a big deal… again, just reporting the issue anyway)

thanks

[edit]-- oh, i’ll add-- it only happens with my laptop/trackpad… my iMac/mouse can stay on for seemingly any amount of time without showing something similar



Software information

Software versions
Rhinoceros version: 5.4.2 (5E411)
Rhinoceros path: /Applications/Rhinoceros.app
IronPython version: 5.1.2015.131
Language: en-US (MacOS default)
macOS version: Version 10.13.6 (Build 17G65)

Plug-ins
None

Third party kernel extensions
com.intel.driver.EnergyDriver (2.0) A139E25A-85BE-378C-94A1-07E2293B6796

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4870HQ CPU @ 2.50GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1920 x 1200
Displays: Color LCD (295dpi 2x)

USB devices
Apple: Internal Memory Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.32.0 355.11.10.10.40.102
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

A: I sometimes had these trackpad issues …

B: I also get 2-finger zooming in Apple Preview de-activated somehow (no change of settings by myself).


This helps — at least for problem B:

change this setting (switch between desktops by 3- / 4-finger-swiping) back and forth:

I reported a similar issue last year. I’m not sure if it’s related to sleep, or maybe as you suggested, sleeping overnight.

1 Like

oh right, i didn’t mention in the first post but yes, this happens (as far as i can gather), after prolonged sleep.

I wasn’t seeing this issue much on my intel based MacBook Pro, but something very similar is happening frequently with my M1 MacBook Pro. When I wake the computer after sleep, the trackpad pan/zoom gestures stop working. Restarting Rhino fixes the problem.

Same issue here, Macbook Pro 15, 2018 / Mac OS 12.1 / Rhino 6.35.21222.17002, 2021-08-10

Had this issue sporadically on older Rhino versions as well, happening more frequently recently. Usually overnight / after sleep.

Anybody found a fix? Really annoying having to restart every couple of days with multiple projects open…