Trackpad – 10.10 Beta (Yosemite Beta)

10.10 & 2015-10-15

I’m also experiencing sluggish(?) navigation with trackpad (two finger view rotation & pinch zooming)…

another thing is that gestures aren’t working at all (macros for 3finger swipes)

I have never seen any sluggish behavior with the trackpad. I’ve made changes in the next WIP release that help fix the zoom / pan confusion. Please test this again with the next WIP release.

[quote=“marlin, post:12, topic:12183, full:true”]
I have never seen any sluggish behavior with the trackpad. [/quote]

with the setting in Rhino Preferences-> Trackpad-> “use two fingers to pan and rotate” enabled

have you tried using a 2finger pinch gesture to zoom?

as far as i can tell, rotating/orbiting/panning are all ok on their own but if you do a 2finger zoom prior to any of them, it appears they too are lagging but i think it’s because rhino is still trying to complete the zoom (it’s as if it zooms in slow motion)

i’m also unable to get any of the 3 finger gestures to register regardless of my trackpad settings in system prefs.

Still couldn’t get sluggish behavior after using a 2 finger zoom. The 2014-11-05 WIP is out and it has changes. I have no idea if this will fix any trackpad issues that have been reported, but I think it will be better.

And trackpad swipes are working again.

trackpad swipes are working for me now as well.

here’s a video in attempt to show the “sluggish” behavior… (latest build- 20141105)

panning and rotate respond as expected… the zoom though? hopefully the video explains it. :wink:
(i didn’t touch the trackpad for the last 10 seconds of the video.)

OK, I (finally) can see this. This will be fixed in the next WIP release.

Just an FYI - this behavior occurs using WIP 20141105 on OS 10.8.5 - not just Yosemite.
The response to trackpad gestures is jumpy, delayed, and often unpredictable…

latest WIP 5A580 two finger to Pan view option sometimes stopped working. Needs to restart Rhino to get it working again.

yeah, i had that happen to me earlier (zooming was poor plus rotating/panning completely quit working)… instead of restarting, i did ‘About Rhinoceros’ under the rhino menu…

for whatever reason, doing that brought back panning/rotating and now my pinch zoom works as well
?

I am still having this problem with the pan in Perspective view, and pinch to zoom also seems to be a nonexistent command.
Shift-two fingers, doesn’t pan in perspective. Pan in other views works and rotate is working fine for me as well. It’s just pan and zoom in perspective that is not working at all.

I am having that issue as well. I’ve never seen Apple sabotage themselves like this before. Something is retarded up at Apple.

I´m having this issue again as I´m using WIP 5A629 on OS X 10.10.2 (Yosemite BETA) now:

Swiping with 2 fingers gets just the zooming.

BUT swiping with 2 fingers while the trackpad is pressed (“clicked”) works correct; it´s just a bit heavy work and not very smooth to use because of that.

I am unable to duplicate this with OS X 10.10.2 (14C81f) and the 2014-12-17 Rhino WIP release. Please post your Rhino information (About Rhinoceros > More info…) so we can see if there is anything else that might cause this problem.

As I again tried to get this issue fixed, I switched on/off Mouse Gestures,

The “scroll with one finger” option was off and thus disabled the trackpad pan/rotate action in some way.

When (now 10.10.2 Beta) this option is active, the trackpad gestures work as intended.

I have the same problem.
Can"t rotate or pan using trackpad (it zooms instead)
It was working before.

Software information

Software versions
Rhinoceros version: 5.0 WIP (5A671)
IronPython version: 5.1.2014.1006
Language: en (MacOS default)
OS X version: Version 10.10.2 (Build 14C106a)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: MacBookAir4,2
Processor: Intel Core i5-2557M CPU @ 1.70GHz
Memory: 4 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel HD Graphics 3000 384 MB
Memory: 384 MB
Screen size: 1440 x 900
Displays: Color LCD (128dpi 1x)

USB devices
Apple Inc.: FaceTime Camera (Built-in)
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Internal Memory Card Reader

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-10.0.19
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: Medium

I am unable to duplicate this with Rhinoceros version 5A671 and OS X version Build 14C106a, the same configuration as you have. Make sure you have the top checkbox checked in Rhinoceros > Preferences > Trackpad.

I solved the problem. I had to check checkboxes in Rhinoceros > Preferences > Magic Mouse ( althouh I don"t use one)

I see that now.

Grumble This looks like a last minute breaking change (for us), and then Apple releases 10.10.2 before we get a chance to look at it.

i saw the 10.10.2 update available in the app store… do you think we should wait a while prior to updating with regards to rhino issues?

(i don’t mind waiting… just that there have been some (possibly overblown?) security alerts out there basically saying to update asap)

I am running Mac OS 10.10.1 and running the latest version of Rhino, and the trackpad zooming and orbiting have completely stopped working. I have tried the previous fixes that have been suggested and nothing works. Is there any solution to this?