Tooltip is affecting performance

I have used Rhino with the tooltip on (showing snaps and distance) for many years now but have only just noticed how badly it affects the performance of Rhino.

When doing any operation that uses the tooltip- drawing, moving etc. (basically everything!) Rhino becomes very laggy and performance appears to drop to about 5fps. The tooltip does not follow the mouse pointer smoothly but instead jumps around jerkily and makes the drawing/transforming process exceedingly annoying. If I turn off the tooltip, drawing and transforming is perfectly smooth and Rhino works great. The problem is I like the tooltip and don’t particularly want to turn it off!

This has been the case on several different computers I have used, so not sure if this is a bug. Has anyone else had this issue or is able to suggest a fix?

Hi Ben - can you run SystemInfo in Rhino and post the results? (I know you said several machines show this but I’d like to get an idea of a system anyway) - Is it in ‘heavy’ files that you see the difference, or all the time?


Hello Pascal - I just tried it in a clean file and the same thing happens, so I don’t think the file size is the problem. I also tried turning on different pieces of tooltip information and it seems like the more things it shows, the problem get slightly worse.

System Info:

Rhino 6 SR24 2020-3-19 (Rhino 6, 6.24.20079.23341, Git hash:master @ 064283610b834170e52117f2656605b5b25d65c0)
License type: Commercial, build 2020-03-19
License details: Cloud Zoo. In use by: Benjamin Baliti ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: VABEL_WK01-01

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro K5200 (NVidia) Memory: 8GB, Driver date: 3-16-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 391.25

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-16-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Ben - just as a test, can you please duisable VisualArq and Tibidabo in Options > Plug-ins, close and reopen Rhino (i.e. without the VisualArq stuff) and see if the same test shows any different results?


I’ve just tried that and it unfortunately doesn’t fix the problem. There’s a possibility the issue does improve very slightly, but its hard to test this quantitatively.

Hi Ben - OK, thanks for testing - I just like to make sure, when I see plug-ins, that they are out of the way for testing.

I am not saying this is the problem, but your Nvidia driver is a couple of years old - you should probably
get the latest from the NVidia website - that would at least eliminate that aspect as well.


Thanks Pascal, I will try that - although as you suggest it may not be the issue.

I wonder if it has anything to do with mouse drivers - I have a gaming mouse, which has it’s own hub software which deals with things like DPI and polling rates. Perhaps these affect the way in which the tooltip works?

Hi Ben - were you able to test that at all?


I’ll test when I have time and get back to you