Tools menu to change the size alone


#1

After customizing my menu bar, at work switches the display from 5 to 6 commands per line, and vice versa at random. At first it took me a few minutes to figure out the problem. I could not find the controls. I think the problem may be connected to the bar of the command line. In some cases, the command is not fully displayed and you need to increase the size of the window menu. In a few moments none of the commands entered in the menu bar responds. I have to close and reopen Rhino.


(Brian James) #2

Hi Simon,

I haven’t been able to reproduce this but my guess from your screenshots is that you are typing commands and the sidebar is changing it’s width or the number of rows of icons is changing. Is that correct? Can you tell me what OSX version you are running? I was using 10.9.1 here and can’t get this to happen.


#3

are you using the jan29 build? (wenatchee 499)… there was a version which was release on jan28 which had a few glitches in it and you should update to the newer one if possible

@BrianJ- the jan28 build had the sidebar dynamically resizing depending on which commands were entered… the latest version appears to be preventing this but there’s still some stuff to sort out. if you run the Trim command, you’ll see that it’s not fitting properly… on the previous build, the workspace shifted to the right to accommodate the size of the trim command which would also rearrange the icons (similar to what the OP is describing)… it’s better now because the workspace isn’t constantly resizing and moving icons around… obviously still needs some fine tuning though.


#4

regarding this:

[quote=“Zsimon, post:1, topic:5536”]In a few moments none of the commands entered in the menu bar responds. I have to close and reopen Rhino.
[/quote]

this sounds like a problem with pushing the ‘Done’ button in the command options… there’s currently a bug associated with that button which locks up the command dialog… avoid using that button for now and instead, use the spacebar or return key or right mouse button to finish a command.


(Brian James) #5

That’s probably it @jeff_hammond , thanks. I’ve filed the issue of cut off command messages and saw it with FilletEdge as well.


(Brian James) #6

I was able to reproduce this in build 499… bug is filed. Thanks for the report.
http://quick.as/pmgxtja3


#7

Hi BrianJ,
I am using 10.9.1 and Rhino 2014 -01-29 (499). Given the problems of the command line, I enabled “use command options dialog” and I solved both problems.