Toolbar and which layer tabs are visible resets after every app launch

Something I’ve noticed in the past few versions of RhinoWIP for Mac is that certain UI elements have started resetting after every app restart. There are two specific examples that I have personally noticed, and it did not happen on previous versions (started maybe 2-3 weeks ago).

The first one is the toolbar on the top of the screen (with buttons: “grid snap”, “ortho”, “planar”, etc), I prefer to keep it hidden. But now it turns back on and I have to re-hide it each time I launch the app.


The second one are the layer tabs (not sure what they’re exactly called, but it’s the checkboxes: “current”, “on”, “lock”, “color”, “material”, etc). Again, I prefer to keep about half of them hidden, but in the last few versions, all of them reset back to “on” after every app launch.

I am currently on Version 8 WIP (8.0.23164.14306, 2023-06-13).

Apologies if anything is missing or if this is not the right way to send feedback, it’s my first time!

Hi, and welcome -

I see that here and put that on the list of things to fix:
RH-75410 Layer: Remember column state
This works as expected on the Windows version. I also tried this with a version that is 7 days from expiring and the same is happening there, so, if this ever worked differently, it is a longer time ago.

This one, I don’t understand. The picture that you show with the Grid SnapHistory buttons, is how things looked in Rhino 7 and before. In Rhino 8, these are put on the status bar and looks like this:

What happens when you run the WindowLayout command and reset the UI to the “Default” layout?
-wim

Yes those buttons have been added to the bottom status bar making the top toolbar redundant, but it still exists. If you go to the Menubar > View > Show/Hide Toolbar, that’s what it looks like on my UI in Rhino 8 WIP. Here you can see the toolbar and status bar together:


Let me know if you still need me to do the WindowLayout thing because I’d rather only reset the UI if it’s totally necessary

Hi ㅂ -

Thanks. It looks like that should not be possible and I’ve added an item on the bug list for a developer to look into removing - RH-75438 Menu: Remove “File > Show Toolbar”

That said, I can’t reproduce the behavior of that setting (show-hide) not sticking between sessions on my machine.

Since the entire UI has undergone major changes throughout the entire WIP phase, it’s possible that something somehow got stuck on your machine that is making it behave like this now.

From your picture, it doesn’t look like you’ve extensively modified the UI but, for starters, you don’t need to loose that customization: WindowLayout lets you save your current UI layout as a custom layout and lets you then switch between one of the defaults and your custom layout(s). I would at the very least try this.

Resetting by using the Reset command or deleting (but first saving a backup) the plist is something to try if the behavior persists.
-wim

I used the Reset and WindowLayout commands like you suggested, and the issue persists in both my custom UI and the default UI. Here you can see in action:


Sorry for the sped up/compressed videos I had to bring the filesize down! Hopefully it’s still visible enough

Hi ㅂ -
RH-75438 Menu: Remove “View > Show Toolbar” ← This one is now resolved by removing that menu item but I’m not sure if that helps you get out of the state that you’re in… Today being July 4th, I don’t think a new public WIP will be available until next Tuesday.

I really should get a bigger screen because that is not only very fast but also very tiny.
It does look, though, like you are only trying the most limited case of resetting, which amounts to the same as reverting to the default window layout. You could try exporting your preferences, resetting them, and then testing to see if that solves the issue. The instructions for doing so are here: Rhino for Mac - Preferences [McNeel Wiki]
-wim