Too many geometrical entities

Hey Guys!
I’m doing a crazy project that is killing my computer. I have 100.000+ Meshes generated in GH and it looks like that:

This is a version with half of the amount of geometry:

My problem is that my computer apparently can’t handle this amount of data. I suspect it’s a problem for my video card (I’m running it on a 2015 MacBook Pro Geforce GT750M with the most powerful configuration).
1 - I’m using mesh because it seems easier for the video card to handle than nurbs.
2 - To compute on GH it takes just a few minutes. To bake it takes hours.
3 - After baking it crashes. It’s computing for half hour and then it responds for half second and then it crashes again and compute for half hour… recursively.
4 - In the command line it says: “AutoSave failed”.
Any guess about how to make it run better? settings? geometry tricks? praying?

Try join all Mesh pieces in GH then baking. This should help.

I would separate it into different patches and bake it one by one to avoid crash.

if autosave failed, perhaps the file is too large to handle, since your geometry is just a bunch of box extrusion with different rotation degree and width, it is much more efficient if you use Blocks. save you more memories.

for Computer set up, sometimes it is useful to pump up more RAM into your system. I have 32 Gb - Twin8x4 so have lots of memory to spare :smiley:

or if you use Vray, use proxy geometry. u can have millions polygons without problem. for massive amount of geometry, proxy works flawlessly. (very useful for grass, or cityblocks in Birdeyeview render)
because the geometry only computed at render time so it doesnt really affect your scene.

here is a sample scene with proxy.simple box scattered on Srf total
1.2 million Polys in a scene