Tolerances


#1

I am working on a model but when i start to dimension the part if the part is exactly 6 mm it shows as 6.0 which i do not want, although if i have a part that is say 6.5mm i want to show the 6.5 so i want to know how to control this so i don’ t have an extra.0 each time where i dont need it. Also how do i view my layout view at 100 percent like autocad? this way i can know how it will look on the actual paper before i go printing. thanks


#2

Not sure if this is what you are looking for…

You will need to do a bit of work to match them up perfectly. To match Autocad layout sheet, you will need to measure actual print space in auto cad, and then make a template in Rhinoceros.


#3

Hi @mitviz, So to summarise you want the dimension to remove the decimal zero if you have a value like 9.0 or 4.0 and only show the 9 or 4, but for cases where there is a decimal value you want to see 9.5 or 4.3 shown?
The only way I can think of is to define 2 x identical Dimension types, and then set the precision of each to 1 and 1.0 respectively.
In your drawing you would then have to manually select all the dimensions with a zero decimal after the point and then under properties panel assign them to the Dimension type which has the Precision set to 1.

For 100% layout, Do your 2D and dimensioning in Model space (Top View) and draw a guide rectangle in top view scaled to the paper size and scale you will be using,
eg. A1=594mmx841mm print size. If you are going to do an A1 layout at 1:20, then draw a rectangle in TOP view 11880mm x 16820mm to represent your layout space at scale, and work inside that block at 1:1.
When making your A1 layout sheet, all you need to do is set the detail scale to 1:20 and position the detail view over the 1:1 A1 reference block you drew. it will all fit and be to correct scale, yet you can still work on the 2D linework etc. in full scale in the model space.
If you find that dimensions are HUGE in model space, then switch off the Dimension Scaling options for the dimension definitions. v4 never had this and I find the auto scaling in v5 abit of a pain since I do my layouts in 1:1 in modelspace mostly, and then use the layout to adjust view scale etc…
I actually find it annoying when a dimension gets scaled out of proportion in layout space or vice versa in model space respectively, so I normally switch off the auto dimension scaling, and work at 1:1 in model space.

Michael VS


#4

Thanks kevjin and mvyess, those are great ideas and seems this is the way to go or just save myself the trouble and send all to autocad. a powerful software such as Rhino really surprises me when it comes to simple things like this that is needed for documentation. I would hate to make two dimension styles just to remove decimal points too, this should be dynamic and update based on the drawings like autocad and also there should be a zoom to 100% papersize option in layouts for viewing drawings. i am begging for this.


(Willem Derks) #5

Hi mtviz (and @KevJin)
Have a look at the command Zoom and the option 1to1 first run _Zoom1To1Calibrate command) is that what you are looking for?
http://docs.mcneel.com/rhino/5/help/en-us/index.htm#commands/zoom.htm#kanchor1961

HTH
-Willem


#6

I dont see this doing anything when i try this command


(Willem Derks) #7

Cab you elaborate; what command are you referring to?

-Willem


#8

Zoom1To1Calibrate command


(Pascal Golay) #9

Hi Mitviz - that should bring up a blue bar that you then measure on screen, with a ruler, and thus are able tell Rhino enough to know what the screen resolution is. Last I checked this bar is 478 pixels, so if you know the dot pitch on the monitor you can work out the length more exactly than measuring it. To automate this , I made a little script a while ago, which I’ll include here - you can unzip and then drag and drop the rvb file onto a V5 window to add

ZoomCalibrate

You are asked for the pixel dimensons and then the diagonal measurement (inches) of the monitor, and it calibrates so that Zoom1to1 should be pretty accurate.

ZoomCalibrator.zip (1.6 KB)

-Pascal


#10

Thanks Pascal!


#11

This is all good but what command do i use next to show me in layout space the actual paper size after print? sorry i found it no worries, zoom 1:1


#12

I would really love a better solution to the dimenion tolerances though, i mean it should be more adapted to the object being measured so i don’t have to keep switching dimension styles to get ride of extra zeros when i dont need it


(Marc Gibeault) #13

For the decimal not showing when it’s zero, you need the option to “not show trailing zeros”, which is not (yet) offered in Rhino.


#14

o man, please give us that good people at Rhino or atleast some plugin


#15

If your default dimstyle is set to hide the zeros, you could over-ride the selected dimensions with a different precision value.


#16

i wish it was dynamic like in autocad


#17

Hi mitviz

Try the below VbScript . After having quoted launches the script that removes the zeros
-runscript (
’************************ toglie gli zeri dopo le virgole alle quote*******************
sub toglieZeri
rhino.unselectAllObjects
rhino.enableredraw vbfalse
rhino.command("_seldim"),0
arrdim=rhino.selectedobjects
rhino.unselectAllObjects
for each el in arrdim
testo=Rhino.DimensionText(el)
'msgbox testo
if not vartype(testo)=vbnull then
np=instrrev(testo,".")
'msgbox “np=”&cstr(np)
do
lun=len(testo)
if np=0 then exit do
nt=instrrev(testo,0)
if nt<lun then exit do
’msgbox “nt=”&cstr(nt)
if nt<np then exit do
testo=left(testo,nt-1)
loop
l=len(testo)
npu=instrrev(testo,".")
if l=npu then
testo=left(testo,l-1)
end if

Rhino.DimensionUserText el, testo
end if
next

rhino.unselectAllObjects
rhino.enableredraw vbtrue
end sub
togliezeri
)

Ciao Vittorio


#18

Thanks Vittorio, will definitely try this


#19

_PrintDisplay State=On Color=Print LayoutLinetypes=On

to see how it’s gonna print.