This surface is making me thirsty

I am trying to recreate a shape (please refer to the red polysurface printscreen) with a depression on the top.
If you check the second print screen you will see how the surfaces gets ‘broken’ in a strange way.

I also uploaded the file with each layer indicating the function of each element in the process of the two rail.

I am trying to CNC and I would like to have a clean shape.

Thanks in advance for your help !

Strip.3dm (3.8 MB)

(Editing: Initial reply had a crease)
Adding a Slash in the sweep2 helps to solve self-intersecting surfaces.
Also had maintain height on. if that changes.

Other way maybe use orient command to add more cross sections so you can control isocurves created.

Strip_sweepAddSlashes.3dm (961.6 KB)

Thanks! Unfortunately I can not open it with RH5 for mac. Your version is newer. Is it possible to know what do you mean with orient? Also how was the criteria to locate the slash.

Regards

Woops my bad. I’ll save it to V5 then should be ok.
Other side is not fixed I think…

Slash (as far as I know) is it adds cross section (isocrv) and reduces the twisting a bit. So I guess right betore and after is ok.

As for orient it is available for mac as well.
Orient is basically a copy command.
you first select what you want to copy, then assign two base points then two target points. You have option to extend it in 3D, or 1D(streching it).
I use orient often for sweep2s.

Strip_sweepAddSlashes.3dm (1005.9 KB)

Some info on orient command:
http://docs.mcneel.com/rhino/5/help/en-us/commands/orient.htm

Ah yes! Orient I know, but I am not sure what for are you using it.
I will check your file and get back to you.
Thanks so much!

I guess it’ll be similar to the adding slash.
So basically you can copy a profile to the point where the problem occurs so that the surface when sweeped does not cause self intersecting.

In the original file you can find that the isocurves are scrunched up and crossing each other causing the crease.

Best is try the sweep command and try out adding the slashes. You can keep the initial surface you made so to check what kind of effect it has. I guess you want to add the slash so the isocurves are spaced out more… I think trying and cntrlZ then trying seems the best way to see how it works…

Ok I think I need to start over explaining to communicate better my process.

Step 1: Rials come from intersection with a polysurface. (Image_1)
Step 2: Sweep two rial using the blue lines (intersection) as rials and green curves located on the middle as profile curves.
Step 3: Get the surface. I think here comes the first anomaly. You can check the image_2
Step 4: Once the surface is there. I want to keep the main part of that surface, but make a transition towards the flat lid.
If you check the image 3 you can see from where to where I want to make the transition. Basically the A red line is the isocurve extracted from the sweep2 riel surface.

Hope this was cleared. I apologize

Is it possible/acceptable to add more
cross sections, the green curve, at this point? using orient command. especially at the corners where problem occurs?
Adding more profiles for better control of how the
sweep is made may help remove the initial
crease.

or adding slashes while sweep2 as below:

If you lke to have flat top surface, You may want to do one sweep2 just for that surface then using the
edges to start the sweep2 for the rest of the parts. If you select edges, the transition should be smooth.(attached file)

Strip_sweepAddSlashes_AddedFlatsurface.3dm (950.7 KB)

Another way was to just use Simplfy setting in the sweep2, it seems to come out ok:
Strip_sweep_AddedFlatsurface_Simplified.3dm (586.4 KB)

I tried to add a curve between the quad of the radius that apparently cause the self-intersecting surface.
Did not work either. Not even with slash added. I am starting to wonder if this has to do with the ‘impossibility’ of the shape or my rhino skills. I mean is the process that I want to execute an ’ error’ or it can be done and I am not aware of the tool to use ?

You can check the print screen.

Regards

I don’t think it’s your rhino skills…
Looking at the screenshot, the red curve you have may need larger radius.
While it’s sweeping, it maybe crossing each other.

The file attached with Simplify setting checked didn’t help either? It looked like the transition was going ok…
hmm…

First, I really appreciate your help.
The file you sent works, but the idea is to get the ‘groove’ the arched profile going till the top…where the red curve is and then become flat. I want the cube looks grooved from the sides. You can refer to the 2nd image with the red volume (beginning of the topic).

I manage to find a better outcome. The curve placed on the radius needs to have as you said a bigger radius.

Look this result:

I am not sure if Zebra is importan but if the surface was ‘correct’ shouldnt be the zebra be even ?

I can share this last file with you if you are interested.

Glad you found a solution.
I hope I was able to help a bit…

As for zebra, it shows the surface continuity so not looking even is ok. It shows whether surfaces are continuous or just tangent and not a smooth transition.

even if the surface is flat, it looks like below so it seems ok…

Do you think my zebra is looking continous? I am cnc this so I do not want any ‘jumps’ needs to be read as a flowing surface.

http://docs.mcneel.com/rhino/5/help/en-us/commands/zebra.htm
If the zebra looks like the G2 in the above link, it’s what you are looking for.

You can also try Emap command to also check the reflections.

I think you will get better results if you make the surface flow along the same lines that the underlying surfaces of the cube that you got the rails from.
Loose_Loft_Strip.3dm (294.3 KB)

I made these surfaces using loose loft but you could get similar result with sweep2 by exploding the 2 rails and make a separate surface from the individual pairs of rails . The profile for the next sweep2 would be the end of the previous sweep2

well then does not look right accordingly to my screenshot.

Hi Ji. Thanks for adding to the discussion. I am not sure if I am not understanding the comment you did.
I am making the sweep 2 rails using the underlaying rials coming from the ‘core surface’ .

I checked your file, which looks super neat, but is not becoming flat on the top. I am trying to make a table therefore I would like to achieve a flat surface on the top.
Please find attached the file here:
Jim_Help.3dm (3.7 MB)

I am not sure if the surface is ‘ok’
I will appreciate if you cant take a look.

Regards

That’s easy. Make one planar surface for the top. Actually you already have that planar surface in the original cube. So just leave that part out when making the rails for sweep2

That looks better. What I was suggesting is to explode the rail curves and make separate surfaces for each of the surfaces in the original cube. That gives you better control. The flow of your sweep surfaces as they go around corners will match the rounded corners in the original cube. What that will accomplish is it will make the flow of each strip match the flow of neighboring strips instead of just random orientations.

sweep2_strip.3dm (321.0 KB)

Thanks Jim. I can see you apply a different set of curves from the file that I sent to you.
Is that correct ?

I added same surface done by parts as you recommended or with continuous rials. I believe the outcome is the same.

All the curves I used are in the file I posted. The curves came from your file. I exploded the rail curves in your file. Exploding doesn’t change the shape of curves.