This is an immediate problem! PP dimensions offset on the print

I still do most of my 2D drawing in ACLT. I’ve been trying to use Rhino on small bits and hopefully transition. I just did this, and the dimensions print offset from their placement in Rhino on screen. Am I doing something wrong? Dimensions are in PP. It displays correctly in the print preview window.

As printed.
RH_print

As seen on screen in RH7
RH_Screen

Rh Settings

Please send a small representative 3dm file and the print setting you’re using to see the problem.

Your current SystemInfo would be helpful too.

Thanks

Here you go.
LADDER_prob.3dm (6.4 MB)

sysinfo.txt (1.2 MB)

Sorry, no.
I need the results of Rhino’s “SystemInfo” command.

Thanks

Rhino 7 SR28 2023-2-27 (Rhino 7, 7.28.23058.03001, Git hash:master @ 4ffc5d7156fbccf2a5d9fcc80e522b3851bc7f6c)
License type: Commercial, build 2023-02-27
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 5-19-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.96
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-19-2022
Driver Version: 30.0.15.1296
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\Calyp\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\2.0.3\Substance.Win.rhp “SubstanceImporter” 2.0.3.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Calyp\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 7\Plug-ins\NamedPositions.rhp “Named Position”

1 Like

Thanks. Your SystemInfo looks fine.

I was able to duplicate the problem in Windows V7.
Another tech tried it on the Mac and reported it was okay.
I’m still digging…

When I used Raster, the dimensions did not shift.
When I used Vector, they did.

I’m not seeing the issue in either.
LADDER_prob.pdf (5.0 MB)
LADDER_prob-raster.pdf (5.6 MB)

@CalypsoArt
Very odd.
For me on Windows 10, the dimensions are shifting when using the Vector option. Raster is fine.
For another Tech here, no problem with either raster or vector.

I’ll add it to the defect list, but I have no idea what’s going on.
Sorry.

https://mcneel.myjetbrains.com/youtrack/issue/RH-74230/Vector-print-from-Layout-shifts-dimensions

Update:
I opened the file in V8 and it complained that the ModelBasePoint was not 0,0,0.
In V7, when I reset the MBP to 0,0,0 the print shifting problem went away.

1 Like

I’ll check that.

Setting ModelBasePoint to 0,0,0 did not fix it for me.

Switching the raster output fixes the offset but looks terrible with my dimension lines barely visible. So not usable.

Strange. Setting the ModelBasePoint to 0,0,0 soted V7 for me for both Vector and Raster printing. The defect is on the pile.

As a test, have you tried printing the file in the V8 WIP?

Printed correctly in Vector in WIP8

Interesting. It did for me too.
At least that is an easy enough work-around for now.

Try exporting to pdf from layout, that works when I have these issues. It is the detail view that gets shifted on print and for some strange reason export works.

How is that done? I see no export option from the layout tab, context, etc. This is for experimentation later, as I re-did in AutoCAD and printed. Trying this on an actual project is a bad idea.

Just select everything on the layout, details, texts, everything. (Ctrl-A and Export then choose PDF as file format)