There is no way to uninstall Flamingo


#1

Due to a Flamingo bug I had two versions of Flamingo installed on the same computer:
Flamingo nXt 5.0 --–and— Flamingo nXt

These two versions were in conflict, so I tried to erase the older one (Flamingo nXt 5.0). It did not work, so I tried to erase both of them. It did not work, so I erased Flamingo registry: \HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\5.0x64\Plug-Ins\fd53f8c4-546d-47d1-8820-e66c97645a97

I still cannot get rid of Flamingo. As you can see in the following screenshot, the Options command shows two Flamingo plugins. The Flamingo nXt 5.0 menu does not work. RT Flamingo tabbed panel does not work either, but its name is listed on the panel menu. ToolbarReset command did not remove the Flamingo nXt 5.0 menu.


#2

I used Windows 10 operating system to uninstall Flamingo, but, as you can see in the following screenshot, Flamingo folders are still there. I erased both folders, but Rhino 5 automatically recreated these folders.


(John Brock) #3

Flamingo nXt 3 and nXt 5 are designed to exist and work fine on the same computer.
What makes you think they can’t?

Flamingo nXt 3 used an installer so you can use the Control Panel tool to uninstall the files it’s installer originally added. This will not remove registry keys or any file you created or customized. They can be ignored or manually deleted.

Flamingo nXt 5 uses the RHI installer so it’s not as easy to remove.

What specific problem are you trying to solve?


#4

I had a problem with decals: FlamingoNXtDecal bug
…and I was getting error message every time I tried to use texture palette.

I have reinstalled Flamingo (Flamingo5_Release_20160627_1417.rhi) and it seems to work. Now I have only one pull-down Flamingo menu: Flamingo nXt 5.0.
Thanks.