The long standing bug - dimensioning circles in the Detail View!

See the video. This bug is causing many problems in the shop!!
Video_2022-01-17_164408.7z (13.3 MB)

Uploading a video would make more sense than a compressed file every person has to download to view.

1 Like

Hi -

Very rarely, a video alone will provide enough information for us to be able to check the issue.
Please run the Rhino SystemInfo command and copy-paste the result here.
In a quick test here, I was not able to reproduce this issue. If you notice any steps that are crucial for this behavior to take place, please describe those steps in as much detail as you can.
-wim

1 Like

Really don’t know what else to describe - on the video is visible that I’m creating a circle, dimensioning it in the model space, then creating a new layout with one detail view, then dimensioning the circle in the layout, then activate the detail view, then zooming an panning in the activated detail view, then deactivate the detail view and the dimension of the circle in the paper space is changing and showing the wrong value.

Rhino 7 SR14 2022-1-10 (Rhino 7, 7.14.22010.17001, Git hash:master @ d8a2d020be8cb487bfc091316ef32170cfc7eddb)
License type: Commercial, build 2022-01-10
License details: Stand-Alone

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 15Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1650 Ti (NVidia) Memory: 4GB, Driver date: 12-29-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.09
> Integrated accelerated graphics device with 1 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 4-23-2021 (M-D-Y).
> Integrated accelerated graphics device with 3 adapter port(s)
- This device is not being used

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-29-2021
Driver Version: 30.0.15.1109
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.14.22010.17001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.14.22010.17001
I

1 Like

Thanks! I’ll get this on the list.
Filed as RH-67054: Annotation: Zooming in detail breaks radius and diameter dimensions on arcs
-wim

RH-67054 is fixed in Rhino 7 Service Release 16 Release Candidate

Works fine now!
Thanks Brian!