Textures in Viewport on old hardware

rhino

(Chris Kuether ) #21

GoogleTranslate is your friend. :grinning::grinning:


(Yataman) #22

I have a similar problem, I wonder if this problem was solved somehow?


(Yataman) #23

okay google!:grinning:


(Jeff Lasor) #24

This problem has been resolved in the 18.Q3 drivers from AMD… If you’re still having issues, please specify your card and drivers.

-J


(Yataman) #25

I have exactly the same video card and driver
AMD FirePro M7740 (dell precision m 6500)

Revision Number

8.911.3.4

Release Date

6/20/2012


(Yataman) #26

please tell me for this video card drivers from other video cards (close ones) may be suitable?eg the 18.Q3 drivers?

It’s a pity that amd didn’t update the driver for this video card since 2012.and I have no other options than to change the video card or the computer? Can I update the open gl separately?


(Jeff Lasor) #27

What problems are you experiencing? You do not have any of the video cards mention in this thread, therefore you cannot be experiencing the same problem… The issues I mention in this thread were very specific to Radeon Pro Wx Series cards. The texturing issues are another issue altogether… is that why you’re referring to?

Given that, what issues are you experiencing? Are you seeing these issues in both V5 and V6?

OpenGL is not a “separate” thing that can be updated… the drivers are what implement the OpenGL functionality, so if there is a bug in the OpenGL system on your machine, the only way to fix it is to update the drivers.

In V6, please run the SystemInfo command and copy and paste the results here.

Thanks,
-Jeff


(Yataman) #28


the creator of this topic, Horia Spirescu, had such problems at the very beginning of the topic (April 16)
in the picture I sent the shaded and color backfasing mode


(Yataman) #29

and the latest driver for this video card works worse with v6 than earlier versions)


(Jeff Lasor) #30

I’m still not sure what the problem is… pictures can be helpful, but only if/when I already understand what it is I’m looking for. Is the problem that you cannot see shaded meshes?

Let’s take it step by step…

  1. Start Rhino
  2. Draw a box
  3. Put the Perspective viewport into Shaded mode

What do you see?

Also, I would reset all of your display modes to their default settings so that you and I are working with the exact same thing.

Lastly, you’re working with a 10 year old OS as well as a 10 year old graphics card…which only supports up to OpenGL 3.x. …and although Rhino should still work “ok”, it’s not going to work at its full capacity.

I suggest (and highly recommend) that sometime in the not too distant future you upgrade to Windows 10 and to one of today’s latest and greatest video cards, that has a minimum of 4GB of GPU memory (but 8GB is more preferable) … if you’re planning on using multiple monitors, then double that memory requirement amount.

In the mean time, please try to provide simple, but exact steps and/or examples that describe and demonstrate the issues you’re having. I will try getting a Windows 7 machine put together using an older FirePro card to see if I can reproduce the problem.

Thanks,
-Jeff


(Yataman) #31

Hello ,
the problem is that in v6 viewport no mode is displayed correctly)
in v5 everything is fine



(Yataman) #32

and here is the mode ghosted


(Jeff Lasor) #33

Well clearly “shaded meshes” are not working on your system (as I mentioned)…this means that V6’s programmable OpenGL pipeline (i.e. Shader architecture) is not working on your system.

It also appears that you’re not using the latest drivers for your system (you have 2010 drivers). I found these 2012), still pretty old, but 2 years newer than the ones you have…and 2 years in graphics drivers is huge.

https://www.amd.com/en/support/professional-graphics/mobile-platforms/firepro-mobility-series/firepro-m7740-mobility

…if you go to that link and expand the “Windows 7 64-bit Edition” link, you will see a “Download” button for the drivers… So the first thing I would try is to download those and install them and see if things are any better. Since this is laptop, I’m not going to be able to replicate your exact hardware configuration (without actually getting my hands on your exact laptop with your exact video card)…which means trying to reproduce this here is going to be quite difficult. So far, all of my old FirePro desktop cards can at least draw shaded meshes.

Please let me know if installing the drivers above actually worked, and if they help V6 run any better.

Note: This should probably be made into its own thread, since it doesn’t really the same thing being discussed in this thread… This thread was initially about textures not showing up for Picture objects… Your issue is that shaded meshes don’t show up at all, in any mode.

Thanks,
-Jeff


(Yataman) #34

Thank you very much
I tried to think all the versions of this driver that I found on the Internet (from the official site amd and Dell), including the 2012 version. Everything works with errors. Even it seems that earlier versions work a little better. Well, okay, (I’m tired to change the versions of these drivers already.) it is good that the version of rhinotu 5 works!). And the difference of the interface between the 5th and 6th versions is not big. I’ve been waiting for one improvement in the interface for a long time, and in version 6 I didn’t find it (I’ll work further in version 5 and wait for 7! (Suddenly amd will update the drivers :slight_smile:
note: my textures also do not display :slight_smile:
Thanks,
-Jeff


(Nathan 'jesterKing' Letwory) #35

What would that improvement be?