Textures in Viewport on old hardware

rhino
unhandled

(Horia Spirescu) #1

Any way to see some textures using my old ati firepro m7740?
They wont show on either geometry picture frames (vray mats or rhino mats) nada
Otherwise Rhino runs smoothly…
Thanks

22222


(Nathan 'jesterKing' Letwory) #2

@jeff, is this a card that still should be able to show textures in Rendered mode? It is Ogl 3.3 maximum .


(Jeff Lasor) #3

Technically it should work, yes…obviously it’s not…which can be for any number of reasons…

@horia.spirescu does any reading/displaying of image files work at all? Viewport wallpapers? Background Bitmaps? Image Backgrounds in display modes?

Go into Artistic mode, what does the background look like?
Poke the blue Render button in toolbar, does the Rhino Render produce the correct image?
What about Raytraced mode? Do you see the textures in that mode?

I suspect that certain shaders are either not working properly or they’re failing altogether.

Please try this…

Start Rhino
Run TestGLWarnings
Close Rhino
Start Rhino
Try your test(s) now and see if you get any error message popping up.

Thanks,
-Jeff


(Horia Spirescu) #4

Hei guys, thx alot for the fast answers.
I ran the test - no warnings. Everything runs smoothly EXCEPT for the picture frames and materials texture display in viewport… check this out (last image is a vray render and displays both picture frame and material corectly):

2

34


(Horia Spirescu) #5

Any hints? :slight_smile: @jeff


(Jeff Lasor) #6

I’m still scratching my head on this one… Trying to think of some other things you can try, but I may need to provide you with a private copy of Rhino that has some diagnostic checks in it… Please given me some time to think about this…and I’ll let you know when I have something.

Thank you for your patience on this one…it’s a very odd one.


(Horia Spirescu) #7

@jeff Its ok hehe. Just a few more hints: I am running Windows 10 Pro (fresh install) and Rhino 6. Display adapter drivers (the ones for the M7740) haven’t been updated (by AMD) since…2012 I think… Plus: Rhino 5 is doing the same thing/viewport issue and I was able to use it one this machine. (last time i did was aprox 3 years ago on win 7)


(Jeff Lasor) #8

Wow, that’s pretty old… I know of at least 3 pretty serious issues that AMD fixed in their FirePro drivers in 2014 and 2015… If V5 is showing the same problem, then I’m not too hopeful that V6 is going to do any better, as it really pushes the video card much harder than V5.

I’ll dig up an old FirePro and see if I can at least reproduce this…and then see if there is any hope in fixing it.

In the mean time, you might want to consider looking into a new computer :slight_smile:

-Jeff


(Horia Spirescu) #9

@jeff Yup, already buying a new machine instead of this one. Old hardware just gets obsolete after some time…So if it’s a pain to further look into this issue, forget about it :slight_smile: really appreciate your time/input though! Btw: not sure its the right place to ask but still-Whats the ideal system/hardware specs for Rhino 6 ? Any suggestions? Thanks a lot!


(Jeff Lasor) #10

Hi @horia.spirescu,

We tend not give out direct recommendations or specific brands of hardware.;…

That being said, what I usually tell users is this:

Get a latest and greatest computer with the best CPU you can afford.
Get as much memory as you can possibly fit into your new computer (I recommend at least 16GB).
Get one of the latest video cards from either NVidia or AMD (although the newer Intel GPUs are working with V6, we’re still seeing some issues with some of them, so for now I would avoid any kind of “embedded” graphics chip solution).
Make sure the video card has at least 4GB of memory (V6 will run with less, but the more video memory you have, the better/smoother V6 will run).
Get as big of an SSD (hard disk) you can afford… This will make everything run smoother and faster, not just Rhino.

Thanks,
-Jeff


(FPU) #11

@jeff

Get one of the latest video cards from either NVidia or AMD.

Is this not an issue anymore?


(Jeff Lasor) #12

Most likely is still an “issue”… If you’re referring to the differences in quality between NVidia’s AA and AMD’s.

-J


(FPU) #13

@jeff Thanks! :grinning:

A few years back ‘ATi + Rhino’ was not quite the best synergy, if i remember correctly. Today no issues with AMD prosumer graphics cards, except difference in AA quality?

Because a Radeon Pro WX 4100 4GB looks like much bang-for-buck.


(Nathan 'jesterKing' Letwory) #14

@FPU, I have at this moment a Radeon Pro WX9100 as the display driver. I personally don’t look much at AA quality, so regarding that I can’t tell - but the card otherwise performs great.


(Jeff Lasor) #15

The Radeon Pro WX series are pretty nice cards… However, we’re in the process of evaluating the 18.Q2 drivers at the moment, and so far, we cannot sign off on them for V6…So if you do get one, I advise you to install the 17.Q4 drivers and not the latest 18.Q2 drivers.

-Jeff


(Jeff Lasor) #16

I just ran through a series of our tests for Rhino V6 using a WX 4100 and the 18.Q2 drivers…and so far things look good… So apparently only the WX 9100 and WX 7100 are impacted by the Q2 drivers (same ASIC so it makes sense).

So as of right now, we’re not seeing any issues with the WX4100 and AMD’s latest drivers.

Hope that helps.
-Jeff


(FPU) #17

@jeff Thanks! :grinning:

Actually, if i’m not mistaken… different chips.

  • Polaris 12 = WX2100 && WX3100
  • Polaris 11 = WX4100
  • Polaris 10 = WX5100 && WX7100
  • Vega = WX9100

Btw, i’m still on Rhino 5. :grimacing:


(Jeff Lasor) #18

@FPU

I need to make a correction here… I hope you haven’t pulled the trigger on the 4100 yet…

Apparently all of the testing I just did was using the 5100 … The 4100 is in my other machine… Once I started testing the 4100, I ran into the same problems I had with the 9100 and 7100 (which doesn’t make sense).

Anyways, as of right now the only WX PROs that seem to be working with the latest Q2 drivers are:

WX 5100
WX 3100
WX 2100

…all others hang and lockup the computer (really bad)… requiring a hard reset of the machine. We’re currently working with AMD at this time to try to resolve this.

-Jeff


(FPU) #19

@jeff Thanks! Indeed, doesn’t make sense. WX5100 && WX7100 are practically the same, besides different number of CUs. (Compute Units)