Textured image loses control

In the latest sr I get this image changing appearance, it can happen if I scroll layers or turn them on and off or if I move the clipping plane.
Noticed this last night modeling and now it’s reoccurring.
It’s just a simple plane with one texture on I’m using as a guide.

Hello - does Reparamterize > Automatic on the plane do anything good?


Hi Pascal,
Before I try that just want to let you know the plane image goes bad but it comes back after some time don’t know what is triggering this.
I just tried your suggestion and I’ll let you know if the above helped.
Thanks for your quick reply.

Hi Pascal,
Sorry the reparametrize doesn’t work. It keeps happening this time with other bitmaps including png and jpegs.
I noticed it happens especially when I lock or turn on and off layers.

Hi @nathanletwory, @pascal
After months and 11 sr releases can’t you fix this bug which for me is a show stopper. This makes it impossible to model over picture frame images. Same problem all these months and it happens turning layers on and off or just selecting things or executing commands.
Can’t you folks please fix this this is keeping me from using V6 seriously…

@3dsynergy Please attach a file that shows this problem for you. Thanks.

Argh this is the problem it happens then it doesn’t. Last few releases I just gave up and did other things and haven’t used Rhino. I decided to install the update today which I did and the problem was still there as you can see in the pic I posted. I saw your reply and I opened the file and the problem is not there anymore. But it was not just in that file it happened in any file even new files. I saw others on the list with I think the same problem can’t think of the threads off hand.
I could send the file privately, I can’t share it here but I don’t know if you will encounter the problem.
Thanks for your quick reply

I haven’t seen this happen on my machine, hence my request for a file.

You can send the files privately using rhino3d.com/upload . Use nathan@mcneel.com as the recipient instead of tech@mcneel.com . I’ll be notified when the upload has been successfully finished.

Still waiting for a file that exhibits the problem.

@3dsynergy, I received your file. The closest I can get to something in this last image you posted is


This though happens because of two surfaces that are in the exact same plane.

I tried playing with the clipping plane as well, but with all other coincident planar surfaces hidden I haven’t seen the weirld stretching as in your first screenshot.

Let me know if there is a specific sequence you do that causes the problem to show up.

Hi Nathan,
In that file it also happens on the vertical or front elevation picture frames not just the ones in the plan view for me. I have surfaces in the exact same position but I turn those layers off so the above doesn’t happen, which I think would be expected. In the pic I sent and in the file I sent the layer structure was set so that coincident surfaces are off and only the pic that displays the problem is/was visible. I also noticed that the front or vertical picture frames begin to go bad and then the other picture frame in plan view follows.
I wonder if windows defender kicking on is doing anything when it’s doing the off hours virus scan? Next time it happens if it does. I’ll check. Currently Rhino is running flawlessly the display is impressively fast in all modes for me.
Thanks for checking really appreciate it.

@3dsynergy, ok, let me know if you run into it again. I’d like to get some good steps to reproduce. It is clear that there is an error somewhere. Once we can reliably reproduce we can also fix.

Thanks for your patience!