Texture smearing

In the attached model, I’ve successfully applied the texture map to 3 of the 4 shapes. For some reason, the map smears on the right side of the front object. Any idea what’s going on here? I’ve tried every style of mapping I can think of.


Untitled.3dm (203.5 KB)

Thanks,
Dennis

I fixed this particular issue by rebuilding the surface with Sweep2. The previous surface was an Open Extrusion. Although other open extrusions in that file mapped fine.
Untitled_002.3dm (210.5 KB)

I don’t know exactly how, but the curve you created the extrusion from isn’t nicely ‘continuous’. If you rebuild the curve then extrude you’ll get a better result. I found that in this particular case you could split the curve in halve and mirror the left side and join the pieces together.

Unfortunately my curve-fu is not good enough to tell you how to investigate, so that will have to get input from those who do. @pascal?

What exactly is “nicely continuous”? The curve was created by drawing a 3 sided shape and the filleting the corners. Why that’s not continuous escapes me!

I guess if the texture is being applied via the UV of the object, then the patrameterization of true arcs (rational curves) and straights is not even- all of these will probably look better and more consistent if you rebuild the input curve to a fairly dense point count.

-Pascal

See attached model
Untitled_003.3dm (187.3 KB)

Hi Dennis - yeah, I see…that is pretty extreme, but in fact neither of the ‘correct’ examples is correct - if you apply a checker pattern you can see the acceleration and deceleration of the texture:

Untitled_003_PG.3dm (179.8 KB)

-Pascal

Thanks Pascal. I’m not exactly sure how I should rebuild the curve though. There are only 11 points. Are you saying I need more points more evenly spaced?
Also, is the checker pattern a standard Rhino material or something you made for the purpose?

D

Hi Dennis - by rebuild, I mean the Rebuild command, with maybe 32 points, degree 3. That holds the shape pretty well and has even parameterization.

-Pascal

Sorry to be such a pain about this but here is what I get with 32 points and a checkerboard material. I can’t seem to get the checker board to repeat even when I adjust the UVW repeat in the material editor.
Untitled_004.3dm (82.3 KB)

Hi Dennis - I set the repeat in the texture controls on the checker texture.
It looks to me like the repeat in the mapping is broken… I’ll dig some more.

https://mcneel.myjetbrains.com/youtrack/issue/RH-47208

Hm. If I copy and paste to a new file it works.

-Pascal

If I copy and paste the object into a new file I can adjust the repeat only by clicking and dragging on the arrows next to the U, V, or W repeat settings. Typing in a value has no effect.