Texture scaling issue - Referenced Blocks

I have a series of fairly large models which are referenced into a single master file for rendering. Each of these individual models contains blocks for windows, doors etc.

I seem to be having an issue whereby the texture scaling of objects within blocks are thrown out when referenced into the master file (Linked / Referenced). The attached image shows a render from the master file, the brickwork above the windows displaying the issue. Some of the pieces show the brickwork fine - these are outside of the window block/cell. However the pieces directly above the window (and inside the block) are distorted. The texture scaling is fine when rendered from the individual file.

This is using Rhino 5 and Maxwell 3.X - I’m not sure if the fault is within the render plug in, or if it’s related to Rhino / referencing etc.

Either way, any pointers would be greatly appreciated?

Many thanks


Hi Sam,

Does this happen if you just use Rhino Render? This would tell us if it is an issue with Maxwell or not. If you can upload just the one block file and include instructions for reproducing this issue it’ll be easier to troubleshoot as well.

Hi Brian,

It appears to be ok in Rhino, or at least in the rendered viewport. I guess this is an issue with the maxwell plugin then.

Slightly unrelated but, i’m finding it quite tricky to use my rendered viewport to judge texture scaling - everything appears black / grey until I start panning. The textures then appear - but the moment i stop panning, it returns to black. Any idea why this might be happening?

(I’m also having an issue with rhino crashing if my remote desktop connection momentarily disconnects - perhaps this is a related graphics card issue?)


That could be system or setting related in your Rhino 5. Check the OpenGL page in Options > View to see what graphics card and driver for it you have installed. You may just need an update from the GPU manufacturer. Also check that Rendered mode is set to defaults settings (Options > View > Display Modes) and see if this also only happens with Maxwell as the active renderer.