Texture map smearing?


#1

I have been noticing texture maps getting smeared on occasion, and in what I would consider an odd manner. Often on picture frames, when it fails half of the surface will be fine, but half will have an approximate 45 degree smearing. Bellow are some screen caps of something similar, but this example doesn’t show the half and half-ness of what I’m seeing with picture frames. The picture frames can usually be fixed by resizing, or by closing and opening Rhino (which makes sending in an example hard). In this example, applying a bump map seems to make the bug more repeatable.

With bump:

Without bump:

Anyone seeing something similar?
OddMapping.3dm (1.8 MB) (texture files should be saved in the 3dm)

Sam


#2

Yeah I’ve seen picture frames go ‘wonky,’ I guess you could call it smearing, and it’s totally random and usually fixed by slightly nudging the surface a bit.


(Pascal Golay) #3

Hi Sam - I see that the Bump messes with things somehow… I’ll poke at it some more. Thanks.

I don’t know if this bug track item comepletely captures what you are seeing but it is what I see so far:
https://mcneel.myjetbrains.com/youtrack/issue/RH-39688

-Pascal


(Brian Gillespie) #4

RH-39688 is fixed in the latest WIP


#5

Smearing of Pictures is still there.

Sam


(Pascal Golay) #6

Hi Sam - it looks OK here in the latest in-house builds - we should put out a WIP this evening - can you check that?

thanks,

-Pascal


#7

Looks like its still there. I have a massive file (1.7GB) which I’m not sure it’s practical to share which does it pretty repeatedly; let me see if I can put together something I can send along that has the same repeatably.

Sam


(Pascal Golay) #8

Darn - OK, - if you can repeat in a more tractable file, that would be great - I tested with the original file provided and it looked correct to me.

thanks,

-Pascal