Texture issues

Hi Guys

I’m having some issues with Shapediver on bellow reference.
(Ref: 483039fc-a671-4a11-80c9-e27cec2f82bd)

It may be something to do with displaying textures.


A few things to keep in mind when working with textures:

  • keep textures reasonably small, ideally below 1MB (files larger than 4MB will not work)
  • make sure to use seamless textures for the best results
  • textures should be square and sizes of 256, 512, 1024 or 2048px

Find more details on texturing in this article:

Also, posting a minimal version of your definition would help us a lot to understand the issue.

Hi Pavol

The largest file is 230 KB. Very low.
I did get it working. But I had to remove the roughness map.

Materials should work also with roughness map. Could you post a minimal version of your definition so we can investigate?

If I upload a model with Walnut texture active. the Walnut displays but when you make teh Oak active through the menu the Oak doesn’t display. Equally if I upload the model with Oak active the Walnut will then not display when selected from the menu. Both textures are 250Kb.

This model was stable until I reuploaded it with the dim lines.

The screenshot looks fine but that’s all I can say without guessing. Please post a minimal version of your definition that replicates the problem and we’ll have a closer look.

Ok I’ve pulled out the definition from the above thread and it works fine on its own.

It looks like it’s something to do with the base rails. see GH file bellow

Texture Fail Test 03.gh (1.1 MB)

I uploaded the model without any issues, only texture mapping of the side rails doesn’t seem to be right.


You can improve the performance of the model and create mesh with our LoftMesh component in the first step to avoid conversion and use XFromGeo component for transformations instead of duplicating objects. Watch the tutorials below and find sample files in the video description.

You got it working! can you share the definition that worked?

I just uploaded the one you shared and it worked fine.

it’s really odd sometimes it works fine, sometime not.
Sometimes it doesn’t even upload at all.

Well I change the file name . reuploaded it and it works fine.