Text Size Control for VaSpace

How should this work? I’m not finding that it performs as expected. If I set it to use my dimension styles (which display fine in detail windows) the text is huge. If I leave it with the default size, it’s smaller than desired. If I assign it to a new text style with different parameters, it doens’t change.

This may be related to the fact that my project, which contains about 50 spaces, takes so long to update any changes that it would be almost as quick to recalculate them all and note them by hand. Is this normal?

Also I accidentally opened my RHino 6 project in RHino7 and edited the Space style to add a volume parameter. When I saved it as Rhino 6 and opened it, the text had shrunken so small it could not be read. All without changing any setting related to text size.

I resolved the size issue by creating a special dimstyle just for my VaSpace style. I couldn’t otherwise seem to get what I needed.

I’m still having a couple of problems though:

  1. How to move the label out of the way of objects on the plan.
  2. How to ensure that a mask can occlude those objects so that the text is legible
  3. Failing 2 and 3, how to move the VaSpace above the objects in the plan so that they can be masked by a hatch between the text and the objects. If the objects in question are a stair, the space is cut out of the drawing by the time it rises high enough for the hatch beneath it to occlude the stair below.

Hi @djhg,
You can control the text size of spaces from the Space styles dialog. There, you can edit the “Dimension style” and assign a Rhino’s “Annotation style”, so the space will take its text features. If you select the “By Parent” option, the space will use the current “Annotation style” (you can check it out in the Rhino Document Properties > Annotation styles).

The text features (size, font, etc…) can override the annotation style text features from the “Text style” dialog, after selecting “Other”:


Hope this helps.

Thanks. Those methods didn’t seem to behave properly until I created a text style only for VaSpaces. But then it worked. There are a lot of variables so it may be my mistake.

I think it’s mostly to do with Drawing scale. VisualARQ likes using 1:1 if you use the text style override, while most annotation styles use a scale of 1:100 or whatever you’re mostly drawing with.