Text rotation changing when exporting as .dwg

Hi,
When I’m exporting a basic 3D model as a .dwg that contains text information, the text changes rotation from running along the x-axis to running down the z-axis. I cannon see anywhere a setting that would correct this, currently I’m having to select the text in AutoCAD and change the rotation to zero.
Help apreciated.
Sam

@samtotty - Can you post a 3dm file that has one text object in it that demonstrates that?
Also, what exact Rhino version as reported in the first line of the output from SystemInfo?
(It doesn’t happen in my simple test, so I’m not doing something the same as you.)

Hi Lowell,
File attached. I’ve also noticed that the text turns when panning round so is readable when looking from both sides, is there an option to change this too?
Thanks for your help.
Example.3dm (709.2 KB)

Hi Sam - It’s a bit easier to help you if you follow the requests… Lowell asked for a file with 1 text object that demonstrates the behavior - there are 195 such objects in your file and I don’t know if I’m looking at the correct one when testing this.

Also, Lowell asked for information from the SystemInfo command - could you run that and paste the result here?

That said - I selected some text and curves in your file:


and exported that to DWG. I then opened that file in Autodesk TrueView:

I don’t know if that is a good way to test what you are seeing?

You can change this for each annotation style:


-wim

Hi - what I did notice is that annotation text isn’t tied to an annotation style. I’ve created item RH-54779 for that. Do you know how this annotation text was created?
-wim

Hi Wim,
Apologies, first part of system info below.

Rhino 6 SR17 2019-8-23 (Rhino 6, 6.17.19235.15041, Git hash:master @ 06b69c5cc21d880aa793a5a7cfd454a66f6213bb)
License type: Commercial, build 2019-08-23

The text is being created in some survey processing software, with the need to output at 3D solids AutoCAD from Rhino as this is what most of our customers use.

This is what the text looks like once I open it in AutoCAD.

Thanks,
Sam

@samtotty - To write 3d solids to Acad, you need to convert the text to geometry first.
You can do that by Exploding the text and using ExtrudeCrv to make it into breps.
It would be pretty easy to automate that process if you had a lot to do.

In your file, the text is all being made with the built-in Default DimStyle. That’s fine, but you can’t change that style, so you can’t change the setting that causes text to flip to be readable in the viewport.

One way around that would be to make a new DimStyle in your file and change the text to that style. Then you could turn off the automatic orientation.
Or, if you explode the text to curves, it will no longer automatically orient to the view direction.

You have a lot of duplicate text in your file. You can use SelDup to select and then delete duplicates.

I don’t know what will make your work flow the best for this. What is the survey processing software? Might it be possible to get some changes there so the output it makes would fit into the process a little better? We could probably help identify some things that would make it go smoother.

Lowell, sorry for the delay in getting back to you, been a hectic week.
Automatic orientation issue is now sorted, thanks, also got rid of the duplicates.
The main issue now is the text direction when exported as dwg file (as 2007 solids).
I’ve attached the original 3dm file containing one example of good text (white) and one bad text (red).
Also attached are images of the text details taken from Rhino. I noticed that there are differences within the text geometry details (X and Y-axis), could it be something to do with this? And is it possible to change this?
GOOD TEXT:


BAD TEXT:


text.dwg (16.6 KB)
text.3dm (236.2 KB)