Text Leader Problem


#1

In the attached file if I try and switch the justification it completely messes up the leader. It also re-does the location of where the stacking fractions are located at.

Text Problem.3dm (90.4 KB)


(Pascal Golay) #2

Yep, I see something is amiss here - thanks. I cannot seem to edit the leader text to make the fractions work.

https://mcneel.myjetbrains.com/youtrack/issue/RH-39127

-Pascal


(Brian Gillespie) #3

RH-39127 is fixed in the latest WIP


(Lowell Walmsley) #4

I guess those Is fixed in WIP messages must be auto generated. Here’s a little more detail on this one - It’s.not as fixed as I’d like.

Notes from the bug report:
Worked on fixing recomposing of strings with bracketed fractions like [[5/8]], especially when the current font is not the same as the style font.
In the case in the bug report RH-39127, some of the characters in the bracketed area and the fraction are arial, the style font and most of the string is Swiss721 cn Bt. That causes a problem in our recomposer. I fixed the composer so it will be harder to get into that situation, but it is still hard to fix the example file - you have to start by deleting the whole area of the brackets and fraction and type it in again.
I have another project that redoes the way the simplified recomposing works that will make this more better , but for now I think it will be a lot harder to get to this condition by accident.
Somewhat Fixes RH-39127


#5

Thanks for reply. The weird part is I didn’t intentionally make them override the font of the fraction. In fact I would have prefer it came from the style. So I went to do some testing to see how it would have happened and first stumble onto this issue. The style of the font is set to CityBlueprint, but the text doesn’t seem to be showing that way?

Font Test.3dm (37.3 KB)


(Lowell Walmsley) #6

Hi Dennis,
No, it’s not your fault the font changed. It happened when the style font had been overridden and we were trying to compose a stacked fraction out of something in [[…]]. (Maybe some other way too.)
I think I’ve made that a lot harder to do, but there’s still some more work to do on it.

Looks like our new display stuff doesn’t show CityBlueprint correctly. Not sure what that’s about. It worked not too long ago, but just not bold or italic.
Do you use CityBlueprint a lot? I hope we can get it fixed soon.
Bug report here: https://mcneel.myjetbrains.com/youtrack/issue/RH-39176


#7

Thanks

No I just picked something random, other than Arial.


(Brian Gillespie) #10

RH-39176 is fixed in the latest WIP