"Text" is extremely slow

Hello - is this new behavior or has it always done this? If new, did you update Rhino to 6.17 and have it start? Can you please try updating to the latest, 6.18,

https://www.rhino3d.com/download/rhino-for-windows/6/latest

Does that make any difference?

-Pascal

Hello Pascal - thanks for your reply.
It still doesn’t perform well.
I also noticed it happens when selecting dimensions too. Anything that has the option to input text on the properties tab causes this issue.

My workaround is not-to-have the properties tab on when clicking a text or dimension, then edit it by double-click.
If properties are on, the whole program freezes…a friend said it happened to him in Rhino 5 and doesn’t remember how he fixed it (not with an update, but tweaking an option…).

_S

Hello - try disabling VRay in Options > Plug-ins page, and then restart Rhino. Does that behave any differently?

-Pascal

I this is just how things work at the moment when a lot of text is on the screen and you have some selected for editing in the properties panel.

Hi all,
Pascal - I tried that, it still doesn’t improve.
Steve - if I start an empty file and create a single text box with a single word, it still slows down when selecting it.

Still no solution…
Thank you all for your input.

I found this discussion:

Where an user posts a video where the text performance is similar to mine:

and he is doing the same workaround as me:

Hi - Please try to focre the GeForce card to be the primary OpenGL device - you should be able to find an “High Performance” setting in the NVIDIA Control Panel. Also, make sure to plug the monitor into the GTX card.

Any difference?
-wim

Thanks Wim.

I updated the OpenGL device and plugged the monitor into the GTX card (system info copied below)…no improvement.
I am using DisplayPort, I will try with HDMI tomorrow and let you know if that works. Could that be the solution?

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 9-26-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 436.48

OpenGL Settings

  • Safe mode: Off*
  • Use accelerated hardware modes: On*
  • Redraw scene when viewports are exposed: On*
  • Anti-alias mode: 4x*
  • Mip Map Filtering: Linear*
  • Anisotropic Filtering Mode: Height*
  • Vendor Name: NVIDIA Corporation*
  • Render version: 4.6*
  • Shading Language: 4.60 NVIDIA*
  • Driver Date: 9-26-2019*
  • Driver Version: 26.21.14.3648*
  • Maximum Texture size: 32768 x 32768*
  • Z-Buffer depth: 24 bits*
  • Maximum Viewport size: 32768 x 32768*
  • Total Video Memory: 6 GB*

I want to check in on this issue please - I have exactly the same behaviour and have had it for months now. Makes using layouts an absolute pain.

Hi Nico - please try with the Properties panel closed - it may be faster for now, until this

https://mcneel.myjetbrains.com/youtrack/issue/RH-57326

is fixed.

-Pascal

Hi Pascal

Yes, that works, but it’s not a sustainable way to use Rhino unfortunately, as I always need Properties handy. Hope this can get sorted out soon!

Hi, I found out that the actual problem (At least for me) is the spell checker, it works poorly on rhino and its over using resources incredibly. My native language is spanish but I use my computer on english, I was writing text on spanish and of course every word was highlighted. I realized that the text box is slow when its loading the spell check and when having words highlighted.

Searched for options to actually turn it off and there are none. The spell check should be removed until there are improvements made on the code to use the Windows 10 spell checker. So I can not turn the spell checker in rhino and windows and my only workaround was to change my system language to spanish for writing and everything is working incredibly smooth, cause I dont even have a single misspell.

I hope this helps you, it really helped.

Have a nice day,

Matías Correa Díaz

2 Likes

wow! that solved my problem here too. I disabled the spell autocorrect from the control panel and it works smoothly again. thanks!

There’s a test command: TestToggleSpellCheckOnAnnotationText in SR 6.30 RC.
Let us know if that helps.

1 Like

RH-60691 is fixed in the latest Service Release Candidate

I encountered this same problem and the test command fixes the sluggishness when selecting text — but as soon as I select any dimension annotations the sluggishness returns and breaks the test command until I run the test command again.

Is there a similar test command for dimension text?

Hi Michael,

Can you explain what you mean by “breaks the test command”?

Thanks

It’s like the spell check gets re-engaged and the software starts to freeze again whenever I select a dimension or text object. I can run the test command again to get the text selection back to normal speed, but if i go to select a dimension the sluggishness returns.

So you confirm that spell checking is off and it turns itself on again after you select a dimension?

Are you restarting Rhino after disabling the spell checker?

Are you on Windows? If so there’s a new release candidate that may improve things.

I will try to reproduce your issue.

Apologies for the delay in updating you, my notifications on this thread were not set properly – I can confirm that the new SR candidate (7.19.22137.7001, 2022-05-17) has fixed the issue for both multiline text and dimension text. Thanks!

1 Like