Text input component working on platform but inactive via backend

In model https://app.shapediver.com/m/1242-01-15 I can enter a value on text input component afiMaterial1Def and see the results in the ShapeDiver viewer, but my web developer finds that the control is unresponsive via the backend. The note coming back from the parameter is saying “This component is currently inactive.” The component is active and functioning in the Grasshopper model.

In case it matters, the string is JSON which the model unpacks and uses to create a material definition.

Is the text input component updatable via the API? If not, what is the best way to send a short (~100-200 characters) JSON string to the model via the API?


The note is just a generic passage coming from the component in Grasshopper, it is not related to the issue.

I just tried to update the parameter using an API call, and it worked fined. I suspect that your web developer did not format the string correctly, or possibly sent the JSON object instead of the stringified version. Below an example of a call that returned without issues:

api.parameters.updateAsync({name: "afiMaterial1Def", value: '{"sl":"2400","sw":"1200","th":"18","ew":"10","sp":"50","gr":"0","c":"155,255,255","t":"","m":"0.16","r":"0.64","b":"","n":"","o":"1","f":"1","dx":"100","dy":"100"}'});

Thank you Mathieu, that has fixed the problem.