Text in a single line/row (NOT single line FONTS)

Howdy everyone,
I’m trying to create text in a single line, but no matter what I do, it wraps after about 25 characters. There are NO carriage returns or line feeds in the text I am entering. How do I make it keep all the words in the sentence on the same horizontal line?!? This wouldn’t be an issue, but text measurements are funky and getting everything on the same line after the fact is TEDIOUS AS HELL. Why does it wrap at all without any explicit instructions to do so?

If you select the block of text placed in your model you will see two small dots, one at top left, the other mid right. Drag the mid right one across to the right to widen the block and more text will fit on a single line.

I am just trying to generate surfaces so I cannot select the text “block”, and I don’t see any dots, but oddly enough, this seems to be a bug DIRECTLY related to the size of the text input window.

Originally, I was using the text entry dialog at its default width. That resulted in wrapped text, so I widened the dialog out until I could see the entire text on one line, but that ALSO resulted in the text being wrapped, so I closed Rhino and posted this.

After I saw Jeremy’s response, I re-opened Rhino, tried to generate the text again, noticed that Rhino remembered the extra width of the dialog, and when I generated the text this time, it was all on one line. Playing with the width of the window only made it start wrapping the text again, even if I stretched it wide enough again, it would still wrap the text, but if I stretched the dialog, closed Rhino and re-opened it again, it would generate the text all on one line.
So it seems that the width of the generated text is, at least in part, dependent on the width of the dialog, but the implementation is buggy.

Hi Keith,

From that description I’m guessing you are trying to create Text Objects, not Text. Sorry, that’s a different ball game. No dots, no reformatting, you just generate curves, surfaces or solids. However, I don’t see your text wrapping issue.


Can you post a file that demonstrates the problem, along with a screen shot of the dialog box showing your text and settings?

p.s. to @John_Brock - looks like marking my post as a solution was premature…

1 Like

It was correct for annotation text which is what was implied in the original post.

As you pointed out TextObject creates geometry, not annotation.

Sure, no criticism intended.

None taken.

Had @Keith1 supplied an example file, a screenshot, or even the command name used then it would be more clear.

As I re-read back over the original post, it’s very clear to me (but incorrect), he was describing the Text command that creates annotations.

I will try to record a video this evening to demonstrate, I don’t think screenshots will be adequate.

1 Like

Basically the text wraps according to how it is fit into the text field when initially created - I assume this is by design, because the alternate behavior would be equally tedious in at least as many cases, I think, but I’ll ask @Alain

-Pascal

And there is no example file. I was starting from a new file, opening the text creation dialog and going from there.

Keith, could you clarify which command/tool you are talking about:

a) TextObject

image

b) Text

image

or c) _-Text

image

Sorry, wasn’t able to make a video last night, still trying to figure out this screen recording software. I am using the Text Object command. Sorry for the confusion, I am not an architect and do not use the annotation tools. I did mention that I was just trying to create surfaces in my second post.

Another option is to first create annotation text so you can drag out the control points and fine tune the positioning.
The Explode it into curves and go from there.

So I managed to create a video demonstrating the problem I am seeing. Sorry, it’s a little on the small side, but it does demonstrate it pretty well.

https://youtu.be/HxiD-t4_DUc

In the first part of the video, I open Rhino, click the TextObject tool, which is narrow (Close to default width) and pre-populated with a long sentence. I click OK, and you can see that the generated text is wrapped to 4 lines. I then delete that text, reopen the TextObject dialog, only now I stretch it so the text is all on one line. When I click OK, the text is now wrapped on 3 lines. Then I close rhino completely and reopen it. Then I click on the TextObject tool, which has retained it’s width from the last time. This time, when I click OK, the text IS all generated on a single line. This is inconsistent, and it seems the width of the generated text is somehow related to the width of the dialog, but not directly.

Hi Keith - that is clear, thanks.
Hm. Testing in our latest here, I can only ever get one line of text. I’ll try a previous version…

I see the problem you describe in 7.4
It appears to be fixed in 7.5 - you can get the fixed (7.5) version by changing the ‘Update frequency’ in Options > Updates and Statistics page to ‘Service release candidate’

-Pascal

That explains it, thanks. I can wait for the official update.