Text & Dims Blurring Out

unhandled

#1

I’m having a problem with text and dims between model space and layout space. I add text/dims to Make2d geometry in model space, then move over to layouts, in paper space I have my title block etc, which has notes added, drawing number etc. When I save to PDF any annotations in model space are blurring out badly, while text which was placed on paper space is crisp and clear. I have never had this issue before. I am running V5 but also noticed this the other day in V6 too, any ideas ? tia


(Lowell Walmsley) #2

Pretty hard to tell what’s going on without example files and some specific details.
It looks like a problem with scaling a raster image.
Also, that looks like a font we may not have. Does this happen with other fonts too?


#3

Hi Lowell, the font is Eurostile, its sharp and clear on the paper space, yet annotations that were applied in model space are quite poor when printed out on paper, or if you zoom into the PDF on a screen :frowning:


#4

Ok, so I have just noticed that altering display modes affects this. If I choose Technical for my display mode the annotations are a much lower quality (if that is the right description). If I choose to keep the display mode to Wireframe the annotations which done in model space are sharp & crisp :thinking:


(Lowell Walmsley) #5

In the pics above, it’s not just the text that’s blurry - all of the line work is blurry too.
I don’t think it has to do with the font. I shouldn’t have mixed that in here.
If you are printing using Raster mode and then zooming in, at some point things are going to get blurry.
How can I duplicate that second picture?


#6

no always have vector selected, raster is no good to me, it seems when selecting technical mode it is having an effect on the annotations, if I leave the detail window in wireframe mode everything looks fine


(Lowell Walmsley) #7

OK, What are the steps I can follow to duplicate that second picture with everything blurry?


#8

Hi Lowell, ok, create some simple geometry, use Make2d, add annotations to the 2d geometry, text, dimensions etc. Then open a layout page, create a detail view of the geometry, select ‘Technical’ display mode. Save out as a PDF, vector. Open the PDF and zoom in a little.
(The images above were done in V5 but I’m pretty sure V6 was behaving like this too at the beginning of the week)


#9

I’ve had the same experience in 6 (don’t remember it if worked the same in 5). It seems that when saving a vector pdf only wireframe viewports will be made into vectors. Shaded technical etc. will all be saved as raster.


#10

HI @CountryGolden, the question is should that be affecting annotations, it’s quite a big issue for us, my drawings are passed on to procurement who place the orders from the drawings, they not only view them in PDF on screen, but also print copies out which are passed to the on site teams :open_mouth:


#11

Hi milezee,

just by looking at the blurry image you posted, i can only guess that somehow the vector output fell back to raster output. this looks like jpg artifacts on both text and lines.

you can verify in Acrobat if there are any lines you can select with the editing tools.

if you need to output crisp raster pdf this thread might be of interest for you:


#12

Hi @dk2079, thanks for the tip, I shall try that work around :slight_smile:. I’m hoping there is a solution to this for vector printing/PDF’s though. It still seems strange that if I keep the detail in default to wireframe the crisp vectors remain, yet if I change the display mode to technical it deteriorates, (btw I have no knowledge of coding or the under the bonnet stuff which powers rhino :blush:)


#13

@lowell Hi Lowell, any news on this ?


(Lowell Walmsley) #14

Sorry, I missed that it wasn’t covered here.
@scottd can explain in to you…


(Scott Davidson) #15

There are many many issues here, so ultimately this will take a sample file to get what everyone wants.

  1. The technical mode is a shaded mode. This means it only can be printed in raster mode. This is the same as Rhino 5. By switching to Technical mode, then not changing the DPI setting it can get Blurry.
  2. The PDF SaveAs functions has a resolution setting. I would set it to 600 DPI or higher. It is possible to get sharp output here, but you will need to experiment to get what you want on this.
  3. If you want pure Vector printing, then use Make 2D to get the correct hidden view you want. This can be printed in Wireframe and be sharp in the PDF file no matter the scale.
  4. There is a plugin that can print Hidden modes as Vector, it is Visual Arq. They have a special display mode that prints into vector.

The thread about sharp printing from the Rhino 6 WIP is older. The current Rhino 6 works properly to get higher resolutions using raster mode.

I am happy to work with on this. Do you have examples of what you are trying to print?


#16

hi Scott, thanks for jumping in. It would be great if Technical mode also had vector output :slight_smile:, but from your explanation it seems not :frowning: . I don’t think our office will be buying Visual Arq just for that feature.
I’m going to be out of the office for a day but will jump back in here if still needing your help, and many thanks for the offer, appreciated :slight_smile:


#17

Hi Scott, I’ve also noticed that saving to PDF using Rhino To PDF annotations are inferior than if I use Microsoft to PDF, the Rhino PDF blurrs out quickly when zooming in


(Scott Davidson) #18

Can you send me an example model? I can compare them with the same thing you are getting.


#19

hi Scott, can I send to you directly ?