Text/Dimensions are Slow in Rhino 7

Just did it, installed the new build and still have the problem. :frowning:

OK - let me see what I can find. As I recall, we did not see this problem, only some users did so it might be hard to track down.

-Pascal

Weirdly I had the same issue in Rhino 6 on my old computer. I got a new computer and when I installed Rhino 6 I didn’t have the problem. Now I have it for Rhino 7.

@JVN - just in case - can you try TestToggleSpellCheckOnAnnotationText and restart Rhino? Does that make any difference?

-Pascal

Tried it. It was already off, but I tried it both ways to no avail.
Thanks

Hi @JVN,

Just some dumb questions, as your problem might be related to what I’m currently experiencing:

  • which font are you using?
  • does the lag duration gets correlated with the text length (the more lines of text you have, the longer the lag lasts)?
  • does your CPU shows anormal activity during the lag? Something like this:

EDIT: @pascal, you might to have a look at the following thread, as this issue still occurs on R7.3:

Hello - @jeffoulet thanks, I’ll see if I can get someone with a bigger brain than mine to look at this.

Here, I do get a lightly larger bump in the cpu graph selecting text than something else, but it is all very small - nothing at all like what you show.

@jeffoulet , @JVN - does it make any difference what font is in the selected text?

-Pascal

Hi @pascal, thanks for having a look at this.

What I’ve found out on my side so far:

TestToggleSpellCheckOnAnnotationText is disabled.

  • regardless the font, the text panel always requires 0,5-1 seconds to be displayed, when an annotation is selected as nothing was selected before. This makes the user experience really frustrating:


    Switching between objects is more fluid and work as expected:

  • by standard fonts (Arial, Times New Roman etc.), it seems to be no lag. By some other fonts families, the lag also does not seem to appear for the main font (let say Encode Sans), but is present for sub-types of that family (Encode Sans Light, Encode Sans Condensed…):

  • finally, the lag length is related to the number of lines in the text object. More lines = heavier lag:

There is definitely some nasty loop somewhere…

Here is the file: text_lag.3dm (84.4 KB)

And my SystemInfo:

Rhino 7 SR3 2021-1-26 (Rhino 7, 7.3.21026.13001, Git hash:master @     33003e99b55b3e99bc54b233a1b4cfd15b4a8ab2)
License type: Commercial, build 2021-01-26
License details: LAN Zoo Network Node

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP 

Standard graphics configuration.
  Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 12-31-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.09
    > Accelerated graphics device with 4 adapter port(s)
        - Windows Main Display attached to adapter port #0
        - Secondary monitor attached to adapter port #1

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 12-31-2020
  Driver Version: 27.21.14.6109
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 5 GB

Rhino plugins that do not ship with Rhino
  C:\Program Files\Rhino 6\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino6.rhp	"Karamba3DLicense"	
  C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp	"bullant"	1.4.4.0
 
Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Commands.rhp	"Commands"	7.3.21026.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7\Plug-ins\RPC.rhp	"RPC"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoLabsTools.rhp	"Rhino Labs Tools"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.3.21026.13001
  C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp	"Legacy Rhino Render"	
  C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.3.21026.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.3.21026.13001
  C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.3.21026.13001
  C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp	"Displacement"
1 Like

@jeffoulet - thank you - this is exactly what we need.
Jeff, the fonts that are slow are not installed, here - are they, on your machine?

image

RH-62653 Text selection lags

Thanks for your patience and perseverance, y’all.

-Pascal

Yup, these fonts families are installed on my PC. See here for instance: Google Fonts
Each one comes with a bunch of ttf for each style:
image

Hi Jeff - thanks - here, if I install the fonts the lag goes away completely, so far.

-Pascal

I’m experiencing this lag issue as well:
When the properties tab is open, Rhino 7 freezes for a approx. 1 second. then freezes again when deselecting text.

I have:

  • The relevant fonts installed in Windows.
  • Updated to the most recent release candidate.

For me this is still an issue, I have everything up to date, all the fonts installed and the problem persists.

Rhino 6 works fine though.

Hi,
We’re investigating this right now.

Hi, any luck on this? I am having the same issue on two totally different machines. I am always having to do text edits in Rhino 5 and paste them into R7 files.

Hi Mike can you please try the 7.6 release candidate, if you have not?

You can get the fixed, I hope, (7.6) version by changing the ‘Update frequency’ in Options > Updates and Statistics page to ‘Service release candidate’

-Pascal

hi Pascal, I have this one:
(7.6.21117.9001, 2021-04-27)
Commercial

darn. Mike, can you verify that it all works more cleanly if the Properties panel is not open? I’ll see if I can find at what point this was supposedly fixed - I know I tested some stuff related to this myself recently.

-Pascal

oh yeah, works no problem with the properties bar closed, but I use the properties bar all the time

For the record, I still have this problem as well