Terrain generator in Ladybug

unhandled

#1

Continuing the discussion from Patch Command, Site terrain flat surface "blobing":

Antonello,
I’m moving the discussion over to Grasshopper, since I had taken over someone else’s thread in “Windows”.

I had the Terrain Generator working for your Vesuvius example but when I tried my location I got an error:


#2

Hi Nick,

the error is because I’m using the same function of LB Decompose Location, this component doesn’t work if the location name has a comma.

if you delete the comma and increase the numOfTiles all should be fine.

P.S. I have to ask Google how to reduce the number of logos, however I think it is not easy to do for free account.


#3

Thank you Antonello, I will give it a try.
After all of this, I have found that I can just bring in the Google location via Sketchup as well.
Nick


#4

Antonello,
That works! Thanks for the hint.
One thing that you may want to look into, is that Google does something odd with high buildings. As you can see in the attached image, it simultaneously makes a plan view and an angled view which is projected over the street. It also made a bump in the mesh at the location in the screen capture, but not at other buildings.
Not sure what you could do about that, but thought you might like to know.


#5

Hi Nick,

it simultaneously makes a plan view and an angled view which is projected over the street.

it depends on Google static maps. Sometimes they are not orthogonal, it can also happens with short buildings.

“It also made a bump in the mesh…”

The bump is because of the planar projection on the mesh, as you can see from the image below also Google Earth has the same problem.


( Charles C.) #6

Hi guys, 2 questions here !

First, what to do when I get the follow error message : something went wrong during the request of images, ( I tried many times without success )

Also Do you know why I’m running a lot into this error message : index out of range. ? (And for apparently no reason… for instance, i run it, it work correctly. Then I change a parameter and it says the error message. So I go back to last settings… and it says the same error message… but it was working 5 min ago… annoying.

1.0_GH_script_site-modeling_CC.gh (386.1 KB)


(Michael Pryor) #7

Ladybug has its own forum. Probably better off asking there: https://discourse.ladybug.tools/


( Charles C.) #8

I’ve been looking for almost and hour how to register to their forum… !! I think you need an invite to register… I send them an e-mail (and I think I did the same whole procedure 1 month ago without success/ answers) :confused:


(Wim Dekeyser) #9

The terrain generation part that was in LB|HB has been a stand-alone grasshopper plug-in for quite some time now and is called Gismo. You should probably update your plug-ins as that might help with some of the errors you are getting.

Gismo has its own forum on the old grasshopper site:


@djordje is the developer.

As for registering on the LB|HB discourse, hopefully @Mostapha can help.


( Charles C.) #10

Yes Wim, I know about gismo !! The thing is Terrain generator in Ladybug is more precise (higher resolution) (1 to 5 meters between pointXY (geo coordinates)) Vs Gismo (20-30m between pointsXY).

I also reinstall the last version of the pluggin… but didn’t changed anything