Technical View Taking A long Time

I have a Rhino file that is 66MB. On a lark I tried setting the view to technical. 5 Hours of CPU time 100 CPU and nothing display. Is this something I should expect from a file this size or is it a symptom of a problem?

You haven’t supplied enough information to hazard a guess.

Please run About Rhinoceros, copy the information to the Clipboard and post it back here.

Also, Zip up the file and send it to us using the File UPload tool on the Support page.
Please include this URL in the description:
Technical View Taking A long Time

With the file and those details we should be able to figure out the problem.

Software information

Software versions
Rhinoceros version: 5.1 (5B161)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.5 (Build 14F1713)


Third party kernel extensions
com.avast.PacketForwarder (2.1)
com.avast.AvastFileShield (3.0.0)

Hardware information

Computer hardware
Hardware model: MacBookPro6,1
Processor: Intel Core i5 CPU M 540 @ 2.53GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 330M 512 MB
Memory: 512 MB
Screen size: 1920 x 1200
Displays: Color LCD (133dpi 1x)

USB devices
Apple Inc.: Built-in iSight
Apple Computer, Inc.: IR Receiver
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: Apple Internal Keyboard / Trackpad

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.0.35 310.90.10.05b12
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: High

Hello @bigjimslade, I’ve had this problem for years now, and haven’t figured it out. I thought slow was normal until I saw the 1.5 second Technical view times on the Holomark thread and noticed that mine takes 2min at 100% cpu to do the same thing. I’ve tried switiching off Hyperthreading, uninstalling all plugins etc. but still technical view is unusable for me. I’ve posted the problem on forums often but nobody has had any advice which worked sofar. My system is i7-(3770) with Quadro6000, 16gb ram, Vray and T-Splines installed(But removing them made no difference to Technical View Times), Rh5-64bit.
Your system seems very different. Only common factor is we’re both running Rh5-64bit.
It would be great if someone has had this problem too and found a solution.? - Michael VS

I’m still working on putting together a minimal example.

I think I got one uploaded.

I had one case where I accidentally dragged part of the drawing (where I would immediately do <CMD/Z> and it took several minutes to update.

I also uploaded a couple of videos showing a related file as the display mode changes. One video has the object in a block. The other has the block exploded.

In all cases it takes several minutes for the model to be displayed in a drawing model (pen, artistic, technical) the first time. After that the switch occurs fast.